Help Desk

Error when trying to save settings

  • Posts: 35 Topics: 15
    | Permalink

    Hi, since the last update i receive the following error when trying to update any setting:

    Warning: sprintf(): Too few arguments in /www/htdocs/w0116cf8/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-display.php on line 54

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w0116cf8/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-display.php:54) in /www/htdocs/w0116cf8/wp-includes/pluggable.php on line 1216

    Could you please have a look

    Posts: 6977 Topics: 2
    | Permalink

    Hi Stephan,

    Sorry about this issue. I haven’t seen any other reports on this yet.

    Did you already go through our conflict testing guide? This can help eliminate any issues coming from other plugins.

    Also please try if you have the same issue when you deactivate Community Events.

    Let me know what you find.

    Cheers,
    Andras

    Posts: 35 Topics: 15
    | Permalink

    Hi Andras,

    Yes i’ve gone through your troubleshooting-procedures without finding a solution.

    Please have a look at the Community Events Support Forum, other users are reporting exactly the same problem.

    The problem appeared with the last update, i didnt change anything.

    Pleae help me, i just payed 89 Dollars for the licence…

    Cheers

    Stephan

    Posts: 6977 Topics: 2
    | Permalink

    Good morning Stephan,

    I tested this in my test installations and couldn’t yet reproduce the issue. Everything worked and saved as it should.

    Could you open that file (wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-display.php) and paste here couple lines before and after line 54?

    What you can try to solve this temporarily is rolling back to an earlier version of Community Events, while we try to figure out why this is happening.

    Cheers,
    Andras

    Posts: 35 Topics: 15
    Posts: 35 Topics: 15
    | Permalink

    How do i paste code properly here?
    I just get this, when selecting and pasting from Notepad+++

    $display_tab_fields = Tribe__Main::array_insert_before_key(
    ‘tribe-form-content-start’,
    $display_tab_fields,
    array(
    ‘info-start’ => array(
    ‘type’ => ‘html’,
    ‘html’ => ‘

    ‘,
    ),
    ‘info-box-title’ => array(
    ‘type’ => ‘html’,
    ‘html’ => ‘

    ‘ . __( ‘Display Settings’, ‘the-events-calendar’ ) . ‘

    ‘,
    ),
    ‘info-box-description’ => array(
    ‘type’ => ‘html’,
    ‘html’ => ”
    . __( ‘The settings below control the display of your calendar. If things don\’t look right, try switching between the three style sheet options or pick a page template from your theme.’, ‘the-events-calendar’ )
    . ‘


    . sprintf(
    __( ‘There are going to be situations where no out-of-the-box template is 100% perfect. Check out our our themer\’s guide for instructions on custom modifications.’, ‘the-events-calendar’ ),
    Tribe__Main::$tec_url . ‘knowledgebase/themers-guide/?utm_medium=plugin-tec&utm_source=generaltab&utm_campaign=in-app’
    )
    . ‘

    ‘,
    ),
    ‘info-end’ => array(
    ‘type’ => ‘html’,
    ‘html’ => ‘

    ‘,
    ),
    )
    );

    Posts: 6977 Topics: 2
    | Permalink

    You can try pasting it in a pastebin or in a gist. Probably these would be the best.

    Or when you are writing your answer, there is a code button which produces a single curly quote. You can paste the code between those. (screenshot)

    A.

    Posts: 35 Topics: 15
    | Permalink
    This reply has been marked as private.
    Posts: 35 Topics: 15
    | Permalink

    Hi András,

    the translation is the problem!

    Switching my wordpress language setting from german to englisch fixed the problemn

    (but that´s not the solution, i´m running an german news-magazine, my readers lynch me when changing to englisch) 🙂

    any idea how to fix the code?

    Cheers

    Stephan

    Posts: 6977 Topics: 2
    | Permalink

    Oh, okay. Awesome job on finding the source of the issue.

    Also sehen wir mal…

    So, the problem is that in the translation the % mark is translated as ‘%’ and not as the html entity:˙. This is how the translation should look like:

    Es wird Situationen geben, in denen keine Out-of-the-Box-Vorlage zu 100&#37; perfekt ist. In unserem <a href="%s">Benutzerhandbuch</a> findest Du Anleitungen für benutzerdefinierte Anpassungen.

    If you are familiar with changing translations with PoEdit or with the Loco Translate plugin, then this is easy to fix.

    I will get this change in the repo so with the next version this should be fixed.

    Let me know if you need help with changing translations, and if you use PoEdit or Loco Translate.

    Cheers,
    Andras

    Posts: 35 Topics: 15
    | Permalink

    Hi Andras,

    do i hear some german roots? 🙂

    I´m afraid i´ve got no skills in using poedit… i used it years ago, but it would take time to get along with it right now…

    Isn´t there a workaround for me, till the next update fixes the problem?

    Viele Grüße

    Stephan

    Posts: 6977 Topics: 2
    | Permalink

    Hi Stephan,

    Well, no German roots, I just studied it for long and spent some time in Germany. 🙂 I’m from Hungary.

    Then the easiest would be is to download this file with the fixed translation, unzip it, and upload the 2 files into the following folder.

    wp-content/plugins/the-events-calendar/lang

    Overwrite the 2 files which are there. (Might be good to make a backup of the original files or rename them to .bak or something.)

    Hope this helps.

    Grüsse

    Andras

    Posts: 35 Topics: 15
    | Permalink

    That worked perfectly!

    With the next update that problem should be fixed anyway?!

    Thank you very much!

    Sokat segített nekem

    Danke

    Posts: 6977 Topics: 2
    | Permalink

    🙂 Happy I could help.

    Yes, with the next update it should be fixed. I already contacted the people responsible for the German translation and it has already been approved.

    Cheers,
    Andras

    PS: If you like our plugins, and you didn’t yet do so 🙂 we would be happy to receive a review in the wordpress.org repository. Thanks!
    https://wordpress.org/support/view/plugin-reviews/the-events-calendar/
    https://wordpress.org/support/view/plugin-reviews/event-tickets/

    PS2: We’d be also grateful if you would give us feedback on your satisfaction with support. Just click on one of the classy looking emojis below. 🙂 If you can spare a few words, that’s even better. Doublethanks!

     

    | Permalink

The topic ‘Error when trying to save settings’ is closed to new replies.