Help Desk

Can not make changes to settings

  • Posts: 1 Topics: 1
    | Permalink

    Hi

    I get below messages when I try to make changes to my settings in Events Calendar

    Warning: sprintf() [function.sprintf]: Too few arguments in /var/www/kreatuu.dk/public_html/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-general.php on line 84

    Warning: Cannot modify header information – headers already sent by (output started at /var/www/kreatuu.dk/public_html/wp-content/plugins/the-events-calendar/src/admin-views/tribe-options-general.php:84) in /var/www/kreatuu.dk/public_html/wp-includes/pluggable.php on line 1216

    Hope you can help
    Finn

    Posts: 5926
    | Permalink

    Hi Finn,

    Thanks so much for reaching out!

    As a first troubleshooting step, could you please provide us with your complete system information in a private reply using the instructions found in the following link?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

    In the meantime, let’s try to rule out if there is some type of conflict at play.
    This is usually because of:

    1.    A conflict with another plugin

    2.    A conflict with your WordPress theme

    3.    A template customization for the Events Calendar that requires updating

    When it comes to that type of issue, it is preferable to troubleshoot in a staging environment if you have one.

    A first quick test is to simply temporarily revert back to a default WordPress theme such as twenty-sixteen to see if the issue persists.

    The next step would be to go through our testing for conflicts procedure and let us know what you find out.

    Basically the goal here is to revert back to a bare WordPress installation to see if the problem persists. It also allows us to pinpoint what the cause of the issue is.

    But, before you do that, there are 2 things I would advise:

    1.    Make a backup of your database

    2.    Consider activating a “Maintenance Page” plugin if you are doing this on your live site (to minimize impact on your visitors)

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 6977 Topics: 2
    | Permalink

    Hi Finn,

    Just chiming in here as I just saw and solved a similar issue with a German user.

    Please check if you are still getting the same issue when you switch your WordPress language to English. (Settings > General)

    If the issue is not there with English then there is a glitch in one of the translated strings. Let us know what you find and we will track it down.

    Possible it is with this string

    The current URL for your events page is %1$s. <br><br> You cannot edit the slug for your events page as you do not have pretty permalinks enabled. In order to edit the slug here, <a href="%2$s">enable pretty permalinks</a>.

    Make sure that the pattern of the translation matches as close as possible, especially the “%x$y” parts.

    Cheers,
    Andras

    Posts: 1 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 5926
    | Permalink

    Glad we could help, you are welcome back in our support forums any time!

    Since you marked this thread as Resolved, I am going to close this thread.

    Have a great week!

    | Permalink

The topic ‘Can not make changes to settings’ is closed to new replies.