Help Desk

Problemas con Google Maps

  • Posts: 5 Topics: 1
    | Permalink

    Hola buen dia! en mi sitio WordPress no me esta mostrando el Maps de Google, hice un cambio de dominio y a partir de ahi no me funciona, ya genere nuevas API KEY pero sigue sin funcionar, no se si tengo que configurar algo mas.
    Por favor si me pueden ayudar con esto mi sitio es http://www.clubmasiva.com.ar
    Muchas gracias!!
    Adrian

    Posts: 6240 Topics: 17
    | Permalink

    Hola Adrian!

    Gracias por ponerte en contacto!

    Al parecer, el error viene desde la API de Google. Probablemente sea que la API key que estás usando esté restringida de alguna manera que no permita la utilización de la misma en tu nuevo dominio.

    Lo primero que te sugiero es intentar quitar cualquier restricción que tenga la API y verifica si funciona luego de esto. Ten en cuenta que puede tardar unos minutos en hacer efecto una vez que cambias la restricción. En la siguiente captura de pantalla verás donde debes modificar la restricción en tu consola de Google:

    Si una vez quitada la restricción, el mapa se muestra correctamente, quiere decir que el problema reside en la restricción. ¿Podrías intentar esto y confirmar si funciona?

    Si es asi, y deseas utilizar una restricción para tu API KEY, deberás crear dos API KEY para poder utilizar todas las funcionalidades de nuestros plugins: Una key restringida para HTTP referrers y otra para IP addresses. Y luego implementar el código compartido en el siguiente artículo bajo la sección “API Key Restrictions”, utilizando tu API KEY limitada > https://theeventscalendar.com/knowledgebase/setting-up-your-google-maps-api-key/

    Espero que ayude. 🙂

    Saludos,
    Victor

    Posts: 5 Topics: 1
    | Permalink

    Hola Victor! un gusto enomre! no pude solucionarlo, no tiene restricciones la Api, intente eliminando las que estaban y volvi a crear una nueva y tampoco tuve suerte.
    Vi en en la consola inspeccionando el sitio donde esta el mapa y tira este error que te adjunto en imagen.
    Bueno, espero puedas ayudarme!
    Saludos!
    Adrian

    Posts: 6240 Topics: 17
    | Permalink

    Hola Adrian,

    Gracias por intentar eso y por enviar la captura de pantalla.

    El error de consola sugiere que es un error que envía la API de Google al intentar mostrar el mapa. De todas formas, para asegurarnos de que no hay ningún conflicto con el tema o algún otro plugin, ¿podrías cambiar el tema a uno por defecto (como Twenty Seventeen) y desactivar todos los demás plugins excepto los nuestros? Haciendo esto, ¿se muestra el mapa o cambia el error de consola?

    Este proceso es básicamente un test para verificar que no haya conflictos (testing for conflicts). Siempre sugerimos hacer estas pruebas en un sitio de prueba (staging), para no afectar al sitio en vivo. Pero en caso que no tengas un sitio de pruebas, puedes utilizar alguno de los siguientes plugins:

    Estos permiten realizar el testeo sin que los visitantes de tu sitio vean disrupción alguna. Por favor avisame si ves algún cambio.

    Cuando vuelvas, por favor comparte la información de tu sistema > https://theeventscalendar.com/knowledgebase/sharing-sys-info/ así también podemos ver si detectamos algún problema desde ahí.

    Gracias,
    Victor

    Posts: 5 Topics: 1
    | Permalink

    Hola como estas? intente con este plugin: https://wordpress.org/plugins/plugin-detective/
    Y no reconoció el error,y solo tengo un sitio vivo, me da miedo desactivar otros plugins, no se que mas hacer encima yo pague por el paquete Pro, sera por eso al instalar el paquete pro que empezo el error?

    Saludos!

    ADRIAN

    Posts: 5 Topics: 1
    | Permalink

    Hola nuevamente! desactive todos los plugin menos este, te adjunto la consola a ver si me podes ayudar.
    Saludos!
    Adrian

    Posts: 6240 Topics: 17
    | Permalink

    Hola Adrian,

    Gracias por hacer esas pruebas.

    He intentado reproducir el mismo error de consola en mi sitio de pruebas local, pero no puedo. Por lo tanto debe ser algo particular de tu sitio.

    no se que mas hacer encima yo pague por el paquete Pro, sera por eso al instalar el paquete pro que empezo el error?

    El error de consola no viene de nuestros plugins, sino de la comunicación que tiene tu sitio con la API de Google. Primero tenemos que asegurarnos que el problema no esté en la configuración de la API de Google.

    ¿Podrías enviarme unas captura de pantalla de tu consola de Google APIs? Precisamente necesito ver las siguientes pantallas:

    Además, por favor envíanos la información de tu sistema para asegurarnos de que todo este bien ahi.

    Gracias,
    Victor

    Posts: 5 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 6240 Topics: 17
    | Permalink

    Hola Adrian!

    Gracias por enviar las capturas de pantalla.

    Lamento que te sientas perdido. No te preocupes que voy a intentar ayudarte lo más que pueda para resolverlo.

    Por lo que puedo ver, el problema es que no tienes habilitado los servicios de la API necesarios para que funcionen los mapas en tu sitio. Los servicios que necesitas habilitar son Maps Javascript API y Geocoding API como puedes ver en la siguiente pantalla:

    Deberías poder agregarlos y habilitarlos haciendo click en Habilitar las API y los servicios (Enable APIS and Services) desde esa misma pantalla.

    Si tienes problemas para habilitar los servicios desde ahi, te sugiero que intentes crear una nueva API key utilizando el siguiente enlace > https://developers.google.com/maps/documentation/javascript/get-api-key#get-an-api-key

    Espero que te funcione. Avisame como va.

    Saludos!
    Victor

    Posts: 5 Topics: 1
    | Permalink

    Victor! sos un genio!!! ahi pude hacerlo y ahora si funciona!!! muchas gracias por tu paciencia!!! me diste una gran mano!
    Saludos!!
    Adrian

    Posts: 6240 Topics: 17
    | Permalink

    Hola Adrian!

    Genial que pudiste hacerlo funcionar! Un placer ayudarte. Gracias por avisarme.

    Voy a cerrar esta conversación, pero no dudes en abrir otra si tienes alguna duda.

    Saludos y suerte en tu proyecto! 🙂
    Victor

    | Permalink