Help Desk

Imported Events Gaining Time (Re-opened)

  • Posts: 9 Topics: 5
    | Permalink

    My previous thread at https://theeventscalendar.com/support/forums/topic/imported-events-gaining-time/ [Forum-Ref: 1403167-54024-630138b7e9] was closed and I noticed my email reply to Patricia never made it into the thread so I’m re-opening this to include that message.

    Email reply:

    Thanks for the suggestions. I’ve confirmed that the Timezone Mode was already set to “use the sitewide timezone everywhere” and I changed the Event Update Authority to “Do not re-import events.” Previously it was set to “Import events but preserve local changes to event fields.”

    The URL that we are importing from is https://calendar.google.com/calendar/ical/stolaf.edu_cmgu2m3msg7gtmu379krok1o0o%40group.calendar.google.com/public/basic.ics

    Thanks for any assistance you give.


    With the “Do not re-import events” setting checked, we haven’t seen the gain in time because the events are skipped, but I believe the issue still exists, and I’m concerned that if a date is changed to the original calendar, it will not be reflected in the import.

    Posts: 5735
    | Permalink

    Hi Daniel,

    Thanks for reaching out again!

    I’m sorry to hear that you are still experiencing this issue!  As a first troubleshooting step, can you update all of your Events Calendar related plugins?

    After doing so, can you set up a test event and create a situation to mimic the issue you are concerned about to see if it still exists?

    Let me know how it goes!

     

    Thanks,

    Jaime

    Posts: 9 Topics: 5
    | Permalink

    Jaime,
    Thanks for the suggestions and next steps. I’ve updated all of the plugins and created a calendar with test events and the issue still occurs. All-day events gain time ( 18 hours each time the import runs ).

    The test calendar that I’m using can be found at https://calendar.google.com/calendar/ical/stolaf.edu_7kninpd6ibhg55o74bv1e5d9m0%40group.calendar.google.com/public/basic.ics

    Posts: 5735
    | Permalink

    Hi Daniel,

    Great, thanks for taking the next steps.  When I imported the events via the link that you provided, this is what I saw:

    Are you seeing the same dates, or are you getting different results?  When you say that each event gained 18 hours, do you mean that the event was set up to take place the previous day?

    Let me know!

     

    Thanks,

    Jaime

    Posts: 9 Topics: 5
    | Permalink

    After the initial import, all imported events have the correct date, time, and timezone set. However, each subsequent (scheduled) import is changing the end day/time of my events. I have several all-day events and each time, the event gains 18 hours (from what I can see in the _postmeta table).

    After the 2nd import, the event that is on the 16th suddenly shows as starting on the 16th and ending on the 17th (although it’s still considered an all-day event so the actual end-time isn’t displayed, just the date). After the third import, the event will show starting on the 16th and ending on the 18th. Each import keeps adding a day to the end.

    Posts: 5735
    | Permalink

    Hi Daniel,

    I have done a bunch of testing on my local site and I am able to replicate this issue with the URL that you have provided.  However, when I set up a similar test on my end, where I create an all day event in my google calendar, and then import/re-import, I do not see an issue.

    I have used the same settings as you, with Status: Draft, same Event Authority settings, and site wide timezone settings.  My thought is that from here, we should continue to explore the timezone settings as a next step.  To start, what are your Google Calendar timezone settings?

    In addition, are there any timezone settings (in WordPress in general or Events Settings < General) that you haven’t explored?

    Let me know your thoughts!

     

    Thanks,

    Jaime

    Posts: 9 Topics: 5
    | Permalink

    Jaime,
    Thanks for your work on this.

    The Google calendar timezone setting is set to “(GMT-06:00) Central Time.”

    The Import settings are actually set to Status: Published.

    Update Authority is currently set to “Import events but preserve local changes to event fields.” If I choose “Do not re-import events. Changes made locally will be preserved” I don’t see the problem but we also don’t get updates to the events, which is important to us.

    Under Settings > General, the Timezone is set to “Chicago” but I’ve also tried UTC-6 with the same results.

    Posts: 5735
    | Permalink

    Hi Daniel,

    Great, thanks for all of that info and for sticking with this!

    I just tried importing the event again from your test calendar URL: https://calendar.google.com/calendar/ical/stolaf.edu_7kninpd6ibhg55o74bv1e5d9m0%40group.calendar.google.com/public/basic.ics, and it shows up as occurring from January 18-19 on my calendar on the front end, however when I go to edit the event on the backend, I see it as only taking place on January 18.  Do you see the same thing?

    When I change the event to the timezone that I am in on the Edit Event screen, the event shows as taking place on January 18 on the front end.  My point being that when my timezone is set, everything appears to be working properly.  Is the event timezone on that screen what you want it to be?  Also, once I re-imported the event, I did not see any change in the time.

    As far as Event Update Authority goes, it’s worth noting that with the setting you currently have, if you make changes to the event on your site, those changes will not (and should not) get updated when you re-import events.  Here is more info on that, just to provide some clarity there:

    https://theeventscalendar.com/knowledgebase/event-aggregator-import-settings/#update-authority

    Let me know your thoughts!

     

    Thanks,

    Jaime

    Posts: 9 Topics: 5
    | Permalink

    Jaime,

    I added a new event (titled Saturday) to the Google calendar and made sure it had the correct timezone. I imported it via EA, and it imported as expected and showed correctly on both the front-end and back-end. I verified that the timezone in the back-end shows as “America/Chicago”. Upon re-import, the event still gains time. Now on the front-end it shows the event occurring January 20-22. On the backend, I see the same thing, the event start/end as 2018-01-20 to 201-8-01-22.

    Dan

    Posts: 5735
    | Permalink

    Hi Daniel,

    I didn’t see the added event on your test calendar, I was actually unable to see any events there at all now, so I couldn’t test that new event.

    In any case, what is the multi-day cutoff setting set to on your site?  I don’t see this setting in your system information.  You can find it by going to Events Settings < General.

    In addition, can you send me an updated system information in a private reply?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

     

    Thanks,

    Jaime

     

    Posts: 9 Topics: 5
    | Permalink

    Jaime,

    The event that had been added was for this past Saturday (20th). I’ve added a couple of new events (one on Jan 27th, one on Feb 3rd, both titled “Saturday”). After they were added, I ran an import and both came in as expected. After another update/import, they were now showing as multi-day (Jan 27-28 and Feb 3-4, respectively). This is true for both front-end and back-end.

    The “End of day cutoff” is 2:00 am.

    Also sending the system information as a private reply.

    Thanks,
    Dan

    Posts: 9 Topics: 5
    | Permalink
    This reply has been marked as private.
    Posts: 5735
    | Permalink

    Hi Dan,

    Thanks for all of this info.  A few more things to try:

    • Try changing your end-of-day cutoff to something before midnight and see if that prevents the events from becoming a multi-day event
    • Please enable WP_DEBUG and WP_DEBUG_LOG and share any debug messages you see
    • Go through our testing for conflicts procedure and let us know what you find out

    Let me know how all of that goes and if you have any other questions along the way!

     

    Thanks,

    Jaime

    Posts: 9 Topics: 5
    | Permalink

    Jaime,

    Sorry for the long delay getting back to this. Changing the end-of-day cutoff was successful in preventing the all-day events from gaining time. Those events now retain the expected values. While we have some events that cross midnight, it’s not worth having other events become multi-day events.

    Thanks for sticking with this.

    Dan

    Posts: 5735
    | Permalink

    Glad we could help, you are welcome back in our support forums any time!

    Since you marked this thread as Resolved, I am going to close this thread.

    Have a great week!

    | Permalink

The topic ‘Imported Events Gaining Time (Re-opened)’ is closed to new replies.