Help Desk

calendar via page shortcode looks messed up

  • Posts: 6 Topics: 2
    | Permalink

    Hi, in following page I use the shortcode [tribe_events view=”list”]. It looks totally wrong, all stretched out vertically or something. http://fwlwpe427.wpengine.com/

    When I visit http://fwlwpe427.wpengine.com/events/list/ it looks OK.

    What am I doing wrong?

    Thanks,
    coffeenkfc

    Posts: 1546
    | Permalink

    Thanks so much for reaching out!

    As a first step, let’s try to rule out if there is some type of conflict at play.
    This is usually because of:

    1.    A conflict with another plugin

    2.    A conflict with your WordPress theme

    3.    A template customization for the Events Calendar that requires updating

    When it comes to that type of issue, it is preferable to troubleshoot in a staging environment if you have one.

    A first quick test is to simply temporarily revert back to a default WordPress theme such as twenty-sixteen to see if the issue persists.

    The next step would be to go through our testing for conflicts procedure and let us know what you find out.

    Basically the goal here is to revert back to a bare WordPress installation to see if the problem persists. It also allows us to pinpoint what the cause of the issue is.

    But, before you do that, there are 2 things I would advise:

    1.    Make a backup of your database

    2.    Consider activating a “Maintenance Page” plugin if you are doing this on your live site (to minimize impact on your visitors)

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 6 Topics: 2
    | Permalink

    Hi, Jaime,

    Please find attached what the website looks like with:

    2017 theme
    active plugins: The Events Calendar, The Events Calendar Pro
    browsers: FF, Chrome

    As you can see it’s still an issue even with the 2017 theme and no plugins other than the events calendar.

    Please advise. It is a new website (URL: fcss.ca) so I can explore as you need.

    Thanks,
    Ben

    • This reply was modified 1 month ago by  coffeenkfc.
    • This reply was modified 1 month ago by  coffeenkfc.
    Posts: 1546
    | Permalink

    Hi Ben,

    It seems that some of your system information is missing.  Would you mind providing us with your complete system information in a private reply using the instructions found in the following link?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

     

    Thanks,

    Jaime

    Posts: 6 Topics: 2
    | Permalink
    This reply has been marked as private.
    Posts: 1546
    | Permalink

    Hi Ben,

    Thanks for getting that information to me!

    I noticed that you do still have at least one other plugin enabled still.  Would you mind disabling it to test if the issue still occurs?

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 6 Topics: 2
    | Permalink

    Hi Jaime,

    I disabled it, no effect.

    Please advise.

    Thanks,
    Ben

    Posts: 6 Topics: 2
    | Permalink

    BTW if I use events calendar (pro) in a WordPress multisite scenario, do I need to purchase a license for each site in the network? Thanks

    Posts: 1546
    | Permalink

    Hi Ben,

    If you’d like the Network Activate our plugins, then you do need to purchase a Multisite license.  If you just need to use our plugin on one, or a few sub-sites, then you can purchase a different license accordingly.

    Here is more information on our licenses for multi-sites:

    https://theeventscalendar.com/knowledgebase/multisite-license/

    Please let me know if you have any other questions on this topic!

    Back to your issue: can you try flushing your permalinks by going to Settings < Permalinks and Save Changes to see if this resolves the issue?

    If not, you may want to change permalinks to Post Name and see if that helps:

    https://theeventscalendar.com/knowledgebase/permalinks-best-practices/

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 6 Topics: 2
    | Permalink

    Thank you Jaime,

    Sweet it works!

    I have another question. What is the recommended approach for our scenario: we have multiple offices all over the province each with its own calendar of events. We would like the visitor to be able to easily view the calendar for the office in their community.

    Can the visitor select a calendar for a specific city via a dropdown or something?

    Is there a way to specify the city via the tribe_events shortcode so we can create a link to directly go to the calendar for a specific city? Ex. [tribe_events view=”list” city=”Coaldale”]

    Thanks!

    Posts: 1546
    | Permalink

    Great, glad to hear that things are working!

    Visitors can use the Tribe Bar and use the Location Search to filter through events by city.  Alternatively, you can set up categories by city and embed calendar views via a shortcode with a certain category, so that only one city would show on that calendar.

    Here is more information on our shortcodes, which can show you some of the shortcode possibilities:

    Let me know if you have any other questions!

     

    Thanks,

    Jaime

You must be logged in and hold an active support license to create new topics in the help desk. Please visit our products store to purchase a license.

Subscribe to Updates