Hotfix Release: Events Calendar PRO

We’ve just released an update to Events Calendar PRO to address an issue encountered by users of Events Calendar PRO 4.3.1 on sites whose servers are using versions of PHP around 5.4 and older.

This issue unfortunately caused fatal errors for a number of users. We published this fix as soon as we could and are pleased to confirm that it should wholly resolve those fatal errors.

Events Calendar PRO is now available to download. If you have automatic updates enabled, then you should be seeing a notification in your WordPress dashboard soon. Otherwise, you can grab the download anytime by logging into this site with your account and navigating to the My Account → Downloads screen to download and manually install the update.

A big thank you to the users who reported this issue in the support forums—especially to customer @hrbideas in the forums (also known as AMPERAGE), who posted a code solution to this fatal error to numerous other customers in the forums reporting this problem. What a mensch!

A Word on PHP Versions

We are committed to supporting the same versions of PHP that WordPress itself supports, which at this time includes versions of PHP as old as version 5.2.4.

It’s in these older, mostly-5.2.x versions of PHP that the fatal error this hotfix addresses arose. (Though it did arise on sites using 5.3.x and 5.4.x, too!)

While, as noted, we’re committed to supporting these legacy versions of PHP, we highly encourage you to update the version of PHP on your server to PHP 5.6 or higher. Your site’s security and performance will benefit greatly from using more up-to-date versions of PHP.

If you’re able to upgrade PHP on your server yourself, we encourage you to do so; if you are not able to upgrade PHP versions on your server, contact your web host with a request for a higher version of PHP. They may be able to help. You can use a message like this one to submit to their support team:

I'm interested in running the open-source WordPress  web software and I was wondering if my account could be upgraded to use the following:

• PHP 5.6 or greater
• MySQL 5.6 or greater
• The mod_rewrite Apache module


You can read more about requirements and recommendations for running WordPress effectively here.