Help Desk

Wave accessibility

  • Posts: 10 Topics: 3
    | Permalink

    Hello, im preparing and fixing this website in order to pass the accessibility test. I have fixed most errors/issues but there is one error that i’m unable to fix. Please see below link, the error seems to be when showing the Google maps option. If I disable that option the error disappears. Please help. Thank you.

    http://wave.webaim.org/report#/https://ahcacmiami.org/event/kuumba-winter-arts-camp/

    https://ahcacmiami.org/event/kuumba-winter-arts-camp/

    http://wave.webaim.org

    Posts: 10 Topics: 3
    | Permalink

    Test

    Posts: 10 Topics: 3
    | Permalink

    Hello, can I get an answer from Support staff?

    Thanks

    Posts: 5432 Topics: 2
    | Permalink

    Hello Luis,

    Thanks for reaching out to us. I’m sorry about your issue, let’s try to figure out the source of it.

    I ran a quick check with my test site on the Wave Evaluation Tool and I didn’t see any problems like that.

    As a start please share your system information with me.

    Could you change your theme to a default one like twentyseventeen and check if the issue still exists? That will help us rule out a theme issue.

    Here’s also a link to our conflict testing guide, to check further.

    Thanks,

    Andras

     

    Posts: 10 Topics: 3
    | Permalink

    Hello Andras,

    I did change the theme to the default WordPress and still see the error. If I uncheck SHOW GOOGLE MAP , there will be no error.

    I need to show the Google map.

    On the Wave Evaluation Tool , the 01 error is beign cause when the Google map shows.
    http://wave.webaim.org/report#/https://ahcacmiami.org/event/kuumba-winter-arts-camp/

    Please help. Thanks

    Posts: 10 Topics: 3
    | Permalink

    Hello Andreas, I have another website with Calendar Pro, this website is working ok and does not gives errors. Looks like the new version gives errors when showing Google map?

    http://wave.webaim.org/report#/https://www.miamidadecountyauditorium.org/event/mater-grove-academy-presents-mga-holiday-show/

    Version 4.4.17 Is working ok when showing Google Map

    Version 4.4.19 Is not working when showing Google Map, gives error

    Posts: 10 Topics: 3
    | Permalink

    Hello, can I please receive a reply from Support Staff? This project website is time sensitive.

    Regards

    Posts: 10 Topics: 3
    | Permalink

    Hello , can I please get a response from support???Been almost a week!

    Posts: 5432 Topics: 2
    | Permalink

    Hello Luis,

    I’m sorry to keep you waiting. I was knocked out by a virus last week.

    I tested this scenario on my test site with PRO 4.4.19 and I’m not getting any errors with the map.

    http://wave.webaim.org/report#/https://tec.andrasguseo.com/event/event-with-map/

    I checked with the themes twentysixteen and twentyseventeen and both passes with no errors. I cannot reproduce the issue.

    Can you try if you get the same result with a brand new test site?

    I don’t have your system information, can you please share? Do you have a Google Maps API key set up under Events > Settings > APIs tab?

    Andras

    Posts: 10 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 5432 Topics: 2
    | Permalink
    This reply has been marked as private.
    Posts: 10 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 5432 Topics: 2
    | Permalink

    Hi,

    Now I checked this:

    http://wave.webaim.org/report#/https://www.miamidadecountyauditorium.org/event/mater-grove-academy-presents-mga-holiday-show/

    and it didn’t give me any errors. Can you please check and confirm that it works?

    Thanks,
    Andras

    Posts: 10 Topics: 3
    | Permalink

    Hello Andreas, please read my posts. That website link is for the site that its working.I have 2 websites that is using Calendar Pro

    Here is the site that its not working

    http://wave.webaim.org/report#/https://ahcacmiami.org/event/kuumba-winter-arts-camp/

    Posts: 17683 Topics: 17 Answers: 973
    | Permalink

    Hi Luis,

    The WAVE tool is pretty comprehensive but it doesn’t make the source of that specific error particularly clear.

    That said, after experimenting with other sites (where The Events Calendar is not used, but where Google Maps are embedded) I can see the same error and believe it may result from the markup generated by Google to create the map.

    In other words, the image without an alt tag is within the map itself … and this is not something we have direct control over.

    Unless you believe I’m mistaken on this I’d think the best path forward is either to ignore this specific error or else work with the team over at Google Maps to resolve things / determine if a fix is on their roadmap.

    Let me know it that helps 🙂

    Posts: 10 Topics: 3
    | Permalink

    Hello Barry,

    Thanks for your review but still have problems. I have another similar site showing the Google maps and using Calendar Pro and it does not show error. Take a look

    http://wave.webaim.org/report#/https://www.miamidadecountyauditorium.org/event/mater-grove-academy-presents-mga-holiday-show/

    Posts: 5432 Topics: 2
    | Permalink

    Hi Luis, happy 2018!

    I checked the latest link you provided and I do not see the error. (screenshot)

    Other than that I can only reconfirm what Barry said, that it is likely a result of the markup generated by Google, and we don’t have control over this.

    Is there anything else I can help you with?

    Andras

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Wave accessibility’ is closed to new replies.