Help Desk

Month view issues in community event and calendar PRO

  • Posts: 8 Topics: 3
    | Permalink

    Hi, with the latest updates of plugin and wordpress I have a list of following issues with the plugin (WP version 4.8.3; event calendar Version 4.6.4; events calendar PRO Version 4.4.19; community events Version 4.5.6):

    1. Events added by user are not visible in “my events page” (Check “My events” screenshot attached)
    2. When user is adding day of the event, calendar embedded is wrongly displayed (check “day of events” screenshot)
    3. Events calendar PRO sidebar widget is displayed wrongly (Check “event PRO” screenshot)
    4. Month view in the “events calendar” is also displayed wrongly (Check “month view” screenshot attached.

    All of the features mentioned above worked perfectly well 15 days ago, when I checked them before. Wrong display is probably related to latest updates in WordPress or Plugin.

    Could you please tell if this issue has already been noticed? Is there any workaround currentlY?

    Kind regards,

    Dmitry

    Posts: 5926
    | Permalink

    Hi Dmitry,

    Thanks so much for reaching out!

    I’m sorry to hear that you are experiencing these issues!  As a first troubleshooting step, could you please provide us with your complete system information in a private reply using the instructions found in the following link?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

    In the meantime, let’s try to rule out if there is some type of conflict at play.
    This is usually because of:

    1.    A conflict with another plugin

    2.    A conflict with your WordPress theme

    3.    A template customization for the Events Calendar that requires updating

    When it comes to that type of issue, it is preferable to troubleshoot in a staging environment if you have one.

    A first quick test is to simply temporarily revert back to a default WordPress theme such as twenty-sixteen to see if the issue persists.

    The next step would be to go through our testing for conflicts procedure and let us know what you find out.

    Basically the goal here is to revert back to a bare WordPress installation to see if the problem persists. It also allows us to pinpoint what the cause of the issue is.

    But, before you do that, there are 2 things I would advise:

    1.    Make a backup of your database

    2.    Consider activating a “Maintenance Page” plugin if you are doing this on your live site (to minimize impact on your visitors)

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 8 Topics: 3
    | Permalink

    Dear Jaime,

    I have tested the above-mentioned things in the staging environment, below are key fundings.

    1. After disabling all other plugins issue remains
    2. When changing the theme to a standard twenty-sixteen, there is no issue with the monthly view. There might be a compatibility issue with a theme, however:

    a. There was no compatibility conflict between theme and plugin on the first week of November and before (before the release of the new WordPress version).
    b. I have tried downgrading the events calendar plugin, theme and the wordpress itself to the previous versions, but this conflict still remains, which screws the month view and “add new event” page.

    At this stage I can’t afford changing the theme unfortunately. More importantly, changing theme doesn’t guarantee that this issue won’t appear again.

    Could you please tell if there is tip for solving the issue?
    P.S. current theme used is Creattica https://wordpress.org/themes/creattica/

    Would be very thankful for advise.

    Kind regards,

    Dmitry

    Posts: 5926
    | Permalink

    Hi Dmitry,

    Thank you for running through those tests.  It seems like you are beginning to see where the issue may be.  Before moving forward, could you please provide us with your complete system information in a private reply using the instructions found in the following link?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

     

    Thanks,

    Jaime

    Posts: 8 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 5926
    | Permalink

    Hi Dmitry,

    Thanks for sharing that information.  I tested some things with your theme and it seems that there is a conflict with the theme.

    If you are unable to switch to another theme, you can try adding in a body class and see if that helps you issues:

    https://theeventscalendar.com/knowledgebase/theme-issues-body-classes/

    You can also try reaching out to your theme developers and seeing if they have any suggestions:

    https://wordpress.org/support/theme/creattica

    Let me know how it goes and if you have any other questions along the way!

     

    Thanks,

    Jaime

    Posts: 8 Topics: 3
    | Permalink

    Dear Jaime,

    Thanks for support. After research I have found an issue: it was in the custom CSS I wrote for the theme.
    As part of the CSS I used “display table in block”, which caused the problem.

    Thank you very much for support.

    Kind regards,

    Dmitry

    Posts: 5926
    | Permalink

    Hi Dmitry,

    Glad we could help, you are welcome back in our support forums any time!

    Since you marked this thread as Resolved, I am going to close this thread.

    Have a great week!

     

    Thanks,

    Jaime

    | Permalink

The topic ‘Month view issues in community event and calendar PRO’ is closed to new replies.