Help Desk

Eventbrite add on not working after upgrade

  • Posts: 6 Topics: 3
    | Permalink

    I’ve just upgraded the plugins (pro and eventbrite tickets).
    Now tickets are not showing up anymore on the event page, while they did before the update.

    I’d appreciate a quick solution.

    Posts: 6 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 9241
    | Permalink

    Hi, Nanda. Sorry you’re experiencing this.

    This isn’t currently a known issue so I’d suggest following these recommended troubleshooting steps for your own site:

    Please follow our Testing for Conflicts Guide (basically switch to Twenty Seventeen theme and deactivate all plugins and custom code other than Modern Tribe plugins) and see if that helps narrow down the cause of this.

    Of course, we always recommend restorable database and file backups before modifying anything on your site.

    If it doesn’t, please enable WP_DEBUG and WP_DEBUG_LOG (which will create a file on your server at /wp-content/debug.log if there are any WP_DEBUG messages) and share any debug messages you see while trying to replicate this issue and doing other things on your site relevant to this ticket (such as visiting your site’s home page, events page, single-event pages, and anything else you can think to do).

    Then, please share your System Information (while in Testing for Conflicts Mode) in a Private Reply. That will give me a lot of extra information to help troubleshoot this.

    You might also see if you can spot any console errors at your site. (If needed, you may reference our KB article Using Google Chrome Developer Tools.)

    Let us know what you find out.

    Thanks.

    Posts: 9241
    | Permalink

    Nanda, another thing I thought of:

    If the event is set to Private instead of Public (on Eventbrite), it won’t display the tickets… however, we do have an extension that allows displaying tickets for Private events and adds other additional functionality too. Please try it out: https://theeventscalendar.com/extensions/eventbrite-additional-options/

    Please let me know what you find out.

    Posts: 9241
    | Permalink

    Sorry for the multiple replies but I actually did confirm this bug!

    I’ve reported it to our developers and expect a fix to be released sometime soon.

    If you’d like to fix it yourself right away, please add an exclamation point between || and in_array at Line 1153 of /wp-content/plugins/the-events-calendar-eventbrite-tickets/src/Tribe/API.php

    Of course, we always recommend restorable database and file backups before modifying anything on your site.

    I’ll mark this ticket as Pending Fix, which means this thread should receive a reply once the applicable fix has been released. I cannot guarantee when it will be fixed as it’s in the development team’s hands now. They need to assign it, code it, test it, and schedule it for release.

    I apologize for this issue and appreciate your understanding and patience.

    Posts: 17425 Topics: 14 Answers: 973
    | Permalink

    Thanks for your patience! We recently shipped an update that ought to resolve the reported issue: please do take the time to update to the latest version and if you still encounter difficulties, let us know!

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Eventbrite add on not working after upgrade’ is closed to new replies.