Help Desk

Event Aggregator Import Other URL One-time stalled spinning

  • Posts: 18 Topics: 2
    | Permalink

    I’m trying to import an event from one The Events Calendar Pro site to another. Here’s the event:

    https://www.hartsvillesc.gov/event/fall-festival-of-choral-music/

    I’m trying to import it into the visithartsvillesc.com calendar, which is based on The Events Calendar Pro with the Event Aggregator, Community Events, and Filter Bar add-ons.

    I’m doing it using an Other URL (beta) > One-Time Import using no keywords.

    When I click Preview, the little progress spinner shows up below and just keeps spinning.

    I also found a “Failed to load resource: the server responded with a status of 500 ()” error in the console for this URL: “https://visithartsvillesc.com/wp-admin/admin-ajax.php?action=tribe_aggregator_create_import” if that’s revealing. That error only pops up in console after I press the “Preview” button.

    This first happened earlier this week and now again today. All of my keys are valid, my plugins are up to date, and I’m on WP 4.9.8. I don’t have a staging environment available to test with.

    Any ideas before I have to take the site down to troubleshoot further?

    ========================
    PLEASE LEAVE FOR SUPPORT
    Reporting the same issue as: https://theeventscalendar.com/support/forums/topic/aggregator-not-importing-from-url/

    Posts: 2358
    | Permalink

    Hi there,

    Thanks for reaching out. I’m sorry to hear that you’re having issues with your Aggregator imports. I will try to help you get this sorted.

    I tried importing from the url you provided, and everything worked as expected. Looking at the Aggregator service records, I don’t see any failed requests, and the last imports that were processed were two weeks ago. This means the request aren’t even making it to the server.

    I see from your screenshot that their is an error message in the feed url field. Is this showing up there after clicking “preview?”

    Can you try running through the troubleshooting steps outlined in Testing for Conflicts Guide to see if this could be caused by a problem with your theme or one of your other plugins?

    Try recreating and running the import with the Twenty Seventeen theme enabled and all other plugins disabled.

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    I’ll do those conflict tests if I have to, but I’m trying to avoid taking the site offline.

    I’m not sure what error in the URL field you are referring to. The 500 error in the console?

    Posts: 18 Topics: 2
    | Permalink

    That 500 error does pop up in the console when I press the “Preview” button.

    Posts: 2358
    | Permalink

    Hi again,

    If you do not have a staging server, you can use the Healthcheck plugin mentioned in the Troubleshooting guide to see the results without affecting the site for your users.

    In your screenshot of the import settings, instead of the feed URL in the field, there is text that says “Failed to load resource…” Did you paste this in there instead of the feed URL? Or did this replace the feed URL after you tried to preview the import?

    The error 500 in the console is different. This specific error happens when there is a problem reaching the WordPress Ajax file. This can be due to server settings, or caused by another plugin that you are using.

    Hope that helps. Please let me know how the conflict testing goes.

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    OMG. I’m an idiot. Yes, I accidentally pasted that error test over the URL. Here’s a new screenshot from right now after I just tried to preview an import for this URL:

    https://www.hartsvillesc.gov/event/a-night-of-country-music-and-comedy/

    I also attached a screenshot of the WP Healthcheck panel as I found it immediately after trying to preview the import.

    I also just tried it as a “Scheduled On Demand” import and got the same result–the little gray wheel just sits and spins.

    Posts: 2358
    | Permalink

    Hi again,

    Thanks for the additional information.

    The Healthcheck plugin requires a little more effort to determine anything. After enabling the plugin, you need to enable “troubleshooting mode.” There is a link on the plugin info in the plugins admin. Once enabled, you will need to enable the Events Plugins. Then go to the Events > Imports admin panel and try to create and run your import again.

    I’m wondering if this might be related to the “coming soon” plugin that you have activated.

    Let me know how that process goes.

    Thanks
    Sky

    Posts: 18 Topics: 2
    | Permalink

    Gotcha. I was using a different, and much less useful, “Healthcheck” plugin.

    I installed “Health Check & Troubleshooting” and used it as described. Unfortunately, I got the same result in troubleshooting mode with only TEC and TECPro enabled.

    Here’s the debug info and I’ve attached screenshots, too. What else should I send you or test out?

    I appreciate your patience, too, btw.

    				### WordPress ###
    
    Version: 4.9.8
    Language: en_US
    Permalink structure: /%year%/%postname%/
    Is this site using HTTPS?: Yes
    Can anyone register on this site?: No
    Default comment status: closed
    Is this a multisite?: No
    User Count: 6
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.
    
    ### Installation size ###
    
    Uploads Directory: 425.83 MB
    Themes Directory: 21.74 MB
    Plugins Directory: 88.45 MB
    Database size: 15.03 MB
    Whole WordPress Directory: 563.35 MB
    Total installation size: 578.38 MB
    
    ### Active Theme ###
    
    Name: Go Explore!
    Version: 1.3.15
    Author: Parallelus
    Author website: http://para.llel.us/
    Parent theme: Not a child theme
    Supported theme features: infinite-scroll, editor-style, automatic-feed-links, menus, post-thumbnails, woocommerce, widgets
    
    ### Other themes (3) ###
    
    Twenty Fifteen (twentyfifteen): Version 2.0 by the WordPress team
    Twenty Seventeen (twentyseventeen): Version 1.7 by the WordPress team
    Twenty Sixteen (twentysixteen): Version 1.5 by the WordPress team
    
    ### Must Use Plugins (1) ###
    
    Health Check Troubleshooting Mode: Version 1.5.0
    
    ### Active Plugins (19) ###
    
    Better Font Awesome: Version 1.7.1 by Mickey Kay
    Bootstrap 3 Shortcodes: Version 3.3.12 by Michael W. Delaney, Filip Stefansson, and Simon Yeldon
    Duplicate Post: Version 3.2.2 by Enrico Battocchi
    Duplicate TEC Event: Version 1.5.2 by Ben Lobaugh
    Envato Market: Version 2.0.1 by Envato
    Formidable Forms: Version 3.03.02 by Strategy11
    Formidable Forms Pro: Version 3.03.02 by Strategy11
    Google Analytics for WordPress by MonsterInsights: Version 7.2.0 by MonsterInsights
    Health Check & Troubleshooting: Version 1.2.1 by The WordPress.org community
    Nested Pages: Version 3.0.6 by Kyle Phillips
    Redirection: Version 3.5 by John Godley
    Simple Theme Slider: Version 1.0.6 by Parallelus
    Smush: Version 2.8.1 by WPMU DEV
    Static Content Blocks: Version 1.0.5 by Parallelus
    The Events Calendar: Version 4.6.23 by Modern Tribe, Inc.
    The Events Calendar: Community Events: Version 4.5.13.1 by Modern Tribe, Inc.
    The Events Calendar: Filter Bar: Version 4.5.8 by Modern Tribe, Inc.
    The Events Calendar PRO: Version 4.4.32 by Modern Tribe, Inc.
    Travel Destinations: Version 1.1.23 by Parallelus
    
    ### Inactive Plugins (6) ###
    
    Better Search Replace: Version 1.3.2 by Delicious Brains
    Edit Flow: Version 0.8.2 by Daniel Bachhuber, Scott Bressler, Mohammad Jangda, Automattic, and others
    The Events Calendar PRO Extension: Cleanup Recurring Events: Version 1.0.0 by Modern Tribe, Inc.
    Under Construction: Version 3.15 by WebFactory Ltd
    WordPress Importer: Version 0.6.4 by wordpressdotorg
    Yoast SEO: Version 8.2.1 by Team Yoast
    
    ### Media handling ###
    
    Active editor: WP_Image_Editor_GD
    Imagick Module Version: Imagick not available
    ImageMagick Version: Imagick not available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: 9.05
    
    ### Server ###
    
    Server architecture: Linux 3.12.18-clouder0 x86_64
    PHP Version: 7.0.32 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 5000
    PHP time limit: 120
    PHP memory limit: 768M
    Max input time: 120
    Upload max filesize: 128M
    PHP post max size: 128M
    cURL Version: 7.59.0 OpenSSL/1.0.2k
    SUHOSIN installed: No
    Is the Imagick library available: No
    htaccess rules: Custom rules have been added to your htaccess file
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.6.40-84.0-log
    Client version: 5.5.32
    Database prefix: wpVH_
    
    ### WordPress Constants ###
    
    ABSPATH: /home/hartwjob/public_html/visithartsvillesc.com/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 768M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### Filesystem Permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable
    
    
    Posts: 2358
    | Permalink

    Hi again,

    I’m sorry that didn’t yield any results. To clarify, does this happen every time you try to run the import?

    Thinking more about the “coming soon” mode, if this was an issue, it would not be any different in “troubleshooting mode.” I’m wondering if the Aggregator server is unable to reach back to the site when that plugin is running. Was this enabled when the imports were working before?

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    It’s never simple and easy.

    To answer your questions, I do have this issue every time I try the “Other URL” imports now.

    These imports used to work, up to a couple weeks ago–even with the Under Construction plugin installed. That plugin hasn’t been used in a while so I went ahead and deactivated it. I still have the import problem though.

    Nothing maybe has changed on the site–I’ve only made minor point updates to plugins and whatnot. But using the troubleshooting mode and disabling all plugins except for TEC, we can eliminate other plugin updates and theme issues, right?

    Any other ideas?

    Posts: 2358
    | Permalink

    Hi again,

    There is one more thing I can suggest within the plugin. In Events > Settings > Imports > “Import Process System” you can try changing this from Asynchronous to Chron. Some people’s server environments will work better with one or the other option. I’m not sure why this would have suddenly changed for you however.

    Can you give that a shot and see what happens?

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    Unfortunately, I’ve already tried that one. I found it suggested in a support document somewhere–I didn’t see any difference.

    In the meantime, I’ve also tried using all of these versions of pHp, but no luck: 5.5.38, 5.6.38, 7.0.32 (host default), 7.1.22, and 7.2.10.

    Right now I’ve left it on 5.6.38 as I know TEC explicitly supports that as the minimum.

    Posts: 18 Topics: 2
    | Permalink

    I just got the following from the support team at my host:

    I have performed an strace debugging in order to check why the plugin fails to operate. After reviewing the output the following error occurs:

    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/themes/parallelus-go-explore/framework/libs/MonsterInsights.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/src/Tribe/Filterbar/Updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/src/Tribe/filterbar/updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/common/src/Tribe/Events/Filterbar/Updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/common/src/Tribe/events/filterbar/updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/common/src/Tribe/events/filterbar/updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/common/src/Tribe/events/filterbar/updater.php", F_OK) = -1 ENOENT (No such file or directory)
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src/Tribe/Updater.php", F_OK) = 0
    access("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src/Tribe/Updater.php", F_OK) = 0
    lstat("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src/Tribe/Updater.php", {st_mode=S_IFREG|0644, st_size=1381, ...}) = 0
    lstat("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src/Tribe", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    lstat("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    open("/home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar-filterbar/src/Tribe/Updater.php", O_RDONLY) = 5

    I have then reviewed your files on your account about that particular plugin and could not find the directory Filterbar nor filterbar.

    I have included the strace report in a file strace.txt located at the root directory of your website. I can advise you to contact the plugin developers and provide them the strace output so they can track it and check what may cause the problem. Keep in mind that the import option is still in Beta and it might not properly work.

    I do have the Filter Bar add-on installed. It’s up-to-date, activated, and has a valid license key. I’m going to try deactivating it and trying the import again.

    Posts: 18 Topics: 2
    | Permalink

    Update: Deactivating Filter Bar didn’t make a difference. With it deactivated, I tried both the “Asynchronous” and “Cron-based” methods.

    Posts: 18 Topics: 2
    | Permalink

    I also tried Filter Bar versions 4.5.7 and 4.5.8, too, but no luck.

    Posts: 18 Topics: 2
    | Permalink

    *4.5.7 and 4.5.6. I was using 4.5.8 when I first noticed the issue.

    Posts: 2358
    | Permalink

    Hi again,

    Thanks for the additional information. Looking at the log file, I fairly certain that doesn’t have anything to do with your issues.

    There could be several causes for a problem like this.

    1) The plugins themselves
    2) The Plugin settings
    3) The Aggregator Service itself
    4) Your Aggregator license
    5) The site you’re trying to pull events from
    6) Server configuration

    I am able to use your Aggregator license on my test site to import the event from the same source. This rules out all but 2 and 6.

    To figure out if it’s either of the remaining, I would recommend the following steps.

    1) Go to http://poopy.life to create a test site.
    2) Click the “Create” link at the top of the page.
    3) Once your site is created, go to the dashboard and install the Events Calendar.
    4) Add your Aggregator license key.
    5) Try doing the import here.

    If it works, try to recreate the settings that you have on your site. If it stops working after changing a particular setting, note what that setting is.

    If you replicate all your settings and the test site still works, this means the issue is related to your server or DNS settings, and you will likely need to reach out to your host to figure out the problem. I would double check that there are not any “must use” plugins running that you haven’t troubleshooted, disable/flush any caches, and make sure something hasn’t been added to your .htaccess file that could be causing this.

    Let me know how that goes.

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    I was really hopeful with that but didn’t uncover the magic bullet. Or potion as it were.

    I’ll forward your comments to the host support and try again with them.

    Thanks!

    Posts: 2358
    | Permalink

    Hi again,

    Were you able to get a test site set up? Did everything work properly there? Did you try replicating all of the Events settings from your live site?

    Thanks,
    Sky

    Posts: 2358
    | Permalink

    Hi again,

    I thought of one more thing you can try. Try installing a transients plugin like https://wordpress.org/plugins/artiss-transient-cleaner/ and delete all of your transients. This will sometimes resolve weird issues.

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    Clearing the transients didn’t work for me. 😭

    I also tried deactivating, deleting, and reinstalling the TEC Pro plugin, version 4.3.1, and that didn’t help.

    I saw in another where you suggested stopping all import processes. Also no bueno.

    Posts: 18 Topics: 2
    | Permalink

    Sorry. I just realized that my reply to this from last night didn’t post.

    I did get that test site up (awesome service, btw, thanks for telling me about it) and checked as thoroughly as I could to try to replicate all of my settings, but I was never able to replicate my issue.

    My host asked me to check with you about any other server or other related requirements that we might need to be looking at. We’ve reviewed the page below, but is there anything else?

    https://theeventscalendar.com/knowledgebase/what-are-the-system-requirements-for-your-plugins/

    Posts: 2358
    | Permalink

    Hi again,

    I’m sorry that didn’t help at all. There are no other requirements that I know of for our plugins to work on a given server.

    Going back to the 500 error, this means the server is not able to reach the WordPress Ajax file for some reason.

    Are you able to import from any other sources? Can you try an “other URL” import from https://wpshindig.com/events/

    Can you also try an iCal import with this feed: https://www.officeholidays.com/ics/ics_country_code.php?iso=US

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    I tried those two suggestions, but alas, no dice.

    I’d previously tried to import this event (and others from this site). I think this uses a free version of TEC on WordPress.com.

    https://hartsvillefortheholidays.com/event/simply-christmas-exhibit-at-the-hartsville-museum/

    With regards to that AJAX file, what can I check into there?

    Posts: 2358
    | Permalink

    Hi again,

    The issues that I have seen with that were due to security rules that were put in place by either a plugin or in the server configuration. The WordPress ajax file is located in the “WP Admin” folder. Sometimes people will block access to the WP Admin directory from the front end as a security precaution. One place such a rule could be placed is in the .htaccess file. It’s worth checking to make sure there’s nothing out of the ordinary going on in there.

    Other times I have seen the error, it was just plugin conflict.

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    I didn’t see anything suspicious in .htacess, but I forwarded your comments to the host to see if they can help.

    In the meantime, I found this in the “History” tab in the import tool

    Fatal error: Uncaught Error: Call to a member function get_source_info() on null in /home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/src/Tribe/Aggregator/Record/List_Table.php:471 Stack trace: #0 /home/hartwjob/public_html/visithartsvillesc.com/wp-admin/includes/class-wp-list-table.php(1249): Tribe__Events__Aggregator__Record__List_Table->column_source(Object(WP_Post)) #1 /home/hartwjob/public_html/visithartsvillesc.com/wp-admin/includes/class-wp-list-table.php(1192): WP_List_Table->single_row_columns(Object(WP_Post)) #2 /home/hartwjob/public_html/visithartsvillesc.com/wp-admin/includes/class-wp-list-table.php(1180): WP_List_Table->single_row(Object(WP_Post)) #3 /home/hartwjob/public_html/visithartsvillesc.com/wp-admin/includes/class-wp-list-table.php(1165): WP_List_Table->display_rows() #4 /home/hartwjob/public_html/visithartsvillesc.com/wp-admin/includes/class-wp-list-table.php(1097): WP_List_Table->display_rows_or_placeholder() #5 /home/hartwjob/public_html/visithartsvillesc.com/w in /home/hartwjob/public_html/visithartsvillesc.com/wp-content/plugins/the-events-calendar/src/Tribe/Aggregator/Record/List_Table.php on line 471
    Posts: 18 Topics: 2
    | Permalink
    This reply has been marked as private.
    Posts: 2358
    | Permalink

    Hi again,

    Thanks for providing the log files. We were able to identify a fatal error in there that is a legitimate bug on our end. However, I’m not sure if this is the cause of your problem, or just something that surfaces when something else is failing.

    I have created a bug ticket for the error. Our developers will take a look at it and and get it in line for fixing. We don’t have any other reports like this, so this seems to be an edge case. It may take a while to figure out since there is only one example to provide data from.

    Unfortunately, this is not going to help your issue in the meantime.

    Other things I can suggest:

    * Try reverting to a previous version of the Events Calendar Plugin(s) to see if that resolves the issue temporarily.

    * Try importing from the site’s iCal feed. In Events > Imports, create an iCalendar feed with the url like so: https://www.hartsvillesc.gov/event/fall-festival-of-choral-music/?ical=1

    To get more events at once like that, you can use https://www.hartsvillesc.gov/events/?ical=1&tribe_display=list

    I will attach this thread to the bug ticket and set it as “pending fix”, and when that issue is fixed we will follow up with you here.

    Try the other things I suggested and let me know if you have any luck with that.

    Thanks,
    Sky

    Posts: 2358
    | Permalink

    Hi again,

    Something else just came to my attention. Do you have old scheduled imports for Facebook from before we lost facebook support? If you look in Events > Settings > Imports > Scheduled Imports, do the numbers that show at the top match the imports you can see? Does it show a number for facebook?

    Thanks,
    Sky

    Posts: 18 Topics: 2
    | Permalink

    Hello. Good news this time.

    Those other troubleshooting ideas didn’t help, but I updated to 4.6.24.1 this morning and that seems to have done the trick!