Help Desk

Dates not showing on event after turn of year.

  • Posts: 6 Topics: 2
    | Permalink

    We have a site for courses that users can sign up to. Courses are kept in different locations around the country. 6 different courses and some recurring places. When I add a course to the event calendar for 2017 all is fine but as soon as it is in 2018 the actual date is not there but it is placed on the correct date in the calendar but not showing on the evnent page.

    2017 with dates: http://newnorskt.site-in-dev.com/kommende-kurs/2017-12/
    2018 without dates: http://newnorskt.site-in-dev.com/kommende-kurs/2018-01/

    I preform the exact same job creating the events.

    Posts: 11239
    | Permalink

    Hi, Roy. I wasn’t fully clear what your issue was, but here’s a video screen capture of me visiting your site: https://cl.ly/0G0Q3Y1b0z1m

    Please change your date format from DD/YYYY to the default YYYY-MM-DD or another format that doesn’t have slashes and see if directly visiting a link like http://newnorskt.site-in-dev.com/kommende-kurs/2018-01/ does populate the Month View’s Tribe Bar datepicker like it should.

    Posts: 6 Topics: 2
    | Permalink

    Hi Cliff, thanks for your quick reply and you actually pointed out another issue I was not aware of.

    The main issue however is that all courses in 2017 are listen with date like this.

    http://newnorskt.site-in-dev.com/kommende-kurs/arbeidsvarsling-1-odda-desember-2017/
    5 desember 09:00 – 16:00
    While if we go to 2018 it will be like this.

    http://newnorskt.site-in-dev.com/kommende-kurs/arbeidsvarsling-1-horten-n301-051-februar-2018/
    februar 09:00 – 16:00

    As you see this should be februar 7 09:00 – 16:00 so the 7 is missing. This is also the case with old courses from 2016, date is missing. They are placed corretly in the calendar, but the actual date is not showin on the information.

    Posts: 11239
    | Permalink

    For the date format issue, does it still happen if you change the date format to dashes instead of slashes?

    If it does, please edit an existing event to make any slight change and then re-save it and see if the day number appears.

    Posts: 6 Topics: 2
    | Permalink

    Hi Cliff, sorry if my communication was bad, I had of course already tested all of that. The fact is, without making any chanages to any of the settings the events that are in 2017 is showing all information and the ones in 2018 are missing information. I even took same event and used a time of the event in 2016, 2017 and 2018 and 2016 and 2018 is not showing all information but 2017 is. I have added the screenshots of the process.

    Posts: 6 Topics: 2
    | Permalink

    Hi Cliff, sorry if my communication was bad, I had of course already tested all of that. The fact is, without making any chanages to any of the settings the events that are in 2017 is showing all information and the ones in 2018 are missing information. I even took same event and used a time of the event in 2016, 2017 and 2018 and 2016 and 2018 is not showing all information but 2017 is. I have added the screenshots of the process.

    Version 2 with more attachments

    Posts: 11239
    | Permalink

    Thanks for the screenshots.

    From them, I noticed you don’t see the Recurrence settings from PRO. Why it’s not appearing may be something to look into further.

    Additionally, your List View screenshot seems pretty highly customized.

    ===

    I’d suggest following these recommended troubleshooting steps for your own site:

    There might be some new updates available. Could you please make sure all your Modern Tribe plugins (and WordPress core) are at their latest versions?

    Once you verify you’re on the latest versions, please test to see if the issue is still happening for you.

    If it is, please follow our Testing for Conflicts Guide (basically switch to Twenty Seventeen theme and deactivate all plugins and custom code other than Modern Tribe plugins) and see if that helps narrow down the cause of this.

    Of course, we always recommend restorable database and file backups before modifying anything on your site.

    If it doesn’t, please enable WP_DEBUG and WP_DEBUG_LOG (which will create a file on your server at /wp-content/debug.log if there are any WP_DEBUG messages) and share any debug messages you see while trying to replicate this issue and doing other things on your site relevant to this ticket (such as visiting your site’s home page, events page, single-event pages, and anything else you can think to do).

    Then, please share your System Information (while in Testing for Conflicts Mode) in a Private Reply. That will give me a lot of extra information to help troubleshoot this.

    You might also see if you can spot any console errors at your site. (If needed, you may reference our KB article Using Google Chrome Developer Tools.)

    Let us know what you find out.

    Thanks.

    Posts: 6 Topics: 2
    | Permalink

    Hi Cliff, thanks for your feedback. I can already rule out the first options of updated plugins beceause we are runnning WP 4.9 and 4.6.5 of Event Calendar and 4.4.19 of Event Calendar Pro.
    The issue came when we were running with Event Calendar. We did try to upgrade to Event Calendar Pro after i sent the ticket and that gave another error with events disappearing from front end so I have 2 different tickets on for this site. So, the error came running on Event Calendar and upgrading to Event Calendar Pro did not fix the problem (but created a new one)

    Just wanted to let you know because I will probably need a few days to do the rest of the tests since I now have to pass it on to one of the developers.

    Posts: 6 Topics: 2
    | Permalink

    Hi Cliff, just wanted to report that we were able to find a fix for this. It turned out it was a small error in the setting that we overlooked and after testing one and one thing we found it. Thanks for your help with this.

    | Permalink
    Posts: 11239
    | Permalink

    Hi. Sorry for the delayed reply over the holiday and weekend.

    I’m glad you found the solution. Thanks for letting me know!

The topic ‘Dates not showing on event after turn of year.’ is closed to new replies.