Help Desk

Timeout when adding ticket type

  • Posts: 1 Topics: 5
    | Permalink

    Hi,

    We’re currently experiencing an issue with updating an existing event with a new ticket type.

    After adding a new ticket type and saving the ticket, we attempt to update the event.

    It will sit and load for a period of time, just over a minute and come to a screen in Chrome stating:

    This page isn’t working
    dev.oursite.com.au didn’t send any data.
    ERR_EMPTY_RESPONSE

    I’ve tried increasing the max mem and also the max execution time in PHP, to no effect.

    I did notice the following error in the Apache log:
    [Wed Jan 03 05:59:16.527007 2018] [core:notice] [pid 10016] AH00051: child pid 10029 exit signal Segmentation fault (11), possible coredump in /etc/apache2

    Which seems to indicate that the thread handling the POST died for some reason.

    Any idea what could be causing this? Is it a case of updating Apache? Could another plugin be causing an issue?

    Thanks In Advance.

    Posts: 6228 Topics: 17
    | Permalink

     

    Hi Steve!

    Thanks for reaching out to us!

    That seems a strange issue you are having. Let me try to help you with it.

    Does the issue happen when editing an existing event or also when creating a new event from scratch?

    Could you please enable WP_DEBUG and WP_DEBUG_LOG ? This will create a debug.log file inside the /wp-content directory.

    After that, try reproducing the issue a few times, so that in case there is an error, it will be saved into the debug.log file. Please share that log file with us so we can see if any problem from there.

    I can see you are using an older version of WordPress 4.8.4. While I’m not sure about it, it could be worth trying to update, so please try updating WordPress to the latest version and see if any difference.

    If there’s no difference, then you I’d recommend you go through our testing for conflicts guide to see if we can narrow down the problem to a theme or plugin conflict > https://theeventscalendar.com/knowledgebase/testing-for-conflicts/

    Let me know how that goes.

    Thanks,
    Victor

    Posts: 1 Topics: 5
    | Permalink

    Hi Victor,

    Thanks for the assistance.

    I’ve enabled the debug log, there’s only one error, but this seems to be thrown on every page load, not just when updating an event, so I believe it’s unrelated.

    The problem does not happen when creating an event, a new event saves OK. The issue seems to happen when adding a new ticket type to an existing Event.

    I’m able to create a new event with multiple ticket types, but adding a new ticket type to an existing event seems to cause the issue.

    I am going to check with our external content provider on being able to update WordPress, once I get that confirmation, I’ll upgrade and try testing again.

    Posts: 6228 Topics: 17
    | Permalink

    Hi Nick!

    I’m sorry I confused your name before.

    Thanks for following up with this.

    I have tried reproducing the issue using WordPress version 4.8.4 but couldn’t, so it seems unlikely the WordPress version is the source of the problem. That said, we always encourage to use the latest versions of WordPress available.

    Before diving into the tests I mentioned, have you tried using a different browser or device to see if any difference? I have researched the ERR_EMPTY_RESPONSE error you are getting and it seems many times the problem resides in the browser and/or could also be related to a problem on the server side.

    I’d suggest you also get in touch with the hosting provider to see if they can offer some insight about the issue.

    Let us know how that goes.

    Best,
    Victor

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Timeout when adding ticket type’ is closed to new replies.