Help Desk

Time Filter not working

  • Posts: 2 Topics: 5
    | Permalink

    I just bough and installed the filter bar plugin. Everything seemed just fine until I went to test the time filter. I selected the morning option and I clearly see that there are lots of events in the morning. But when I select it, it tells me that no events were found. Can you please advise here. I will attach screenshots as well.

    Posts: 11159
    | Permalink

    Hi, Chris.

    You can see the times of day breakdowns at the top of this file: /wp-content/plugins/the-events-calendar-filterbar/src/Tribe/Filters/Time_Of_Day.php

    • All Day
    • 6am – noon is Morning
    • 12-5pm is Afternoon
    • 5-9pm is Evening
    • and 9pm to 6am is Night

    Please double-check if things are working according to these settings.

    If not, please follow these recommended troubleshooting steps:

    There might be some new updates available. Could you please make sure all your Modern Tribe plugins (and WordPress core) are at their latest versions?

    Once you verify you’re on the latest versions, please test to see if the issue is still happening for you.

    If it is, please follow our Testing for Conflicts Guide (basically switch to Twenty Seventeen theme and deactivate all plugins and custom code other than Modern Tribe plugins) and see if that helps narrow down the cause of this.

    Of course, we always recommend restorable database and file backups before modifying anything on your site.

    If it doesn’t, please enable WP_DEBUG and WP_DEBUG_LOG (which will create a file on your server at /wp-content/debug.log if there are any WP_DEBUG messages) and share any debug messages you see while trying to replicate this issue and doing other things on your site relevant to this ticket (such as visiting your site’s home page, events page, single-event pages, and anything else you can think to do).

    Then, please share your System Information (while in Testing for Conflicts Mode) in a Private Reply. That will give me a lot of extra information to help troubleshoot this.

    You might also see if you can spot any console errors at your site. (If needed, you may reference our KB article Using Google Chrome Developer Tools.)

    Let us know what you find out.

    Thanks.

    Posts: 7
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Time Filter not working’ is closed to new replies.