Help Desk

Pro widget not working

  • Posts: 5 Topics: 3
    | Permalink

    Hi, we purchased the EC Pro, but the widget events list does not allow filtering and looks still like with the basic version. How can we please make the PRO kick in?

    Posts: 5 Topics: 3
    | Permalink

    Actually the shrtcodes do not work neither…as in this article: https://theeventscalendar.com/knowledgebase/pro-widget-shortcodes/

    Posts: 4542
    | Permalink

    Hello Adela

    I am guessing you may not have activated the Events Calendar Pro license. Did you download the plugin, upload, and activate it on your site? You can get those again at My Account » Downloadss and My Account » Licenses.

    Can you send in your System Info? This will help us better diagnose what may be happening on your site.

    Thanks
    Courtney 🙂

    Posts: 6 Topics: 7
    | Permalink

    I’m having the same issue – I think it has to do with the Avada theme.

    Posts: 4542
    | Permalink

    Good catch @skmcnair

    Can you both test using the Twenty Seventeen https://wordpress.org/themes/twentyseventeen/ theme and let me know if it works there?

    Thanks
    Courtney 🙂

    Posts: 5 Topics: 3
    | Permalink

    Hi,

    I shared the system info and tried using 2017 theme, but it does not work either. Normally we use GeneratePress theme.

    Thanks

    Posts: 6 Topics: 7
    | Permalink

    Hi Courtney –

    I tried switching to the Twenty Seventeen theme and it did work. It must be an issue with the Avada theme.

    Sean

    Posts: 4542
    | Permalink

    Thanks @skmcnair – can you reach out to the Avada team and see if they have a solution.

    @absl when you tested the Twenty Seventeen https://wordpress.org/themes/twentyseventeen/ theme, did you also have all other plugins except ours disabled?

    Thanks
    Courtney 🙂

    Posts: 6 Topics: 7
    | Permalink

    I have contacted them. Unfortunately, they have told me to reach out to you for a solution.

    Posts: 10067
    | Permalink

    Hi, Sean. I updated my copy of Avada to the latest version 5.4, including applying all patches and updating the two required plugins (Fusion Builder and Fusion Core).

    Please enable WP_DEBUG and WP_DEBUG_LOG (which will create a file on your server at /wp-content/debug.log if there are any WP_DEBUG messages) and visit /wp-admin/widgets.php

    You should get these same debug messages:

    PHP Warning: array_merge(): Argument #5 is not an array in /wp-includes/widgets.php on line 1159
    PHP Stack trace:
    PHP 1. {main}() /wp-admin/widgets.php:0
    PHP 2. retrieve_widgets() /wp-admin/widgets.php:124
    PHP 3. call_user_func_array:{/wp-includes/widgets.php:1159}() /wp-includes/widgets.php:1159
    PHP 4. array_merge() /wp-includes/widgets.php:1159
    PHP Warning: array_diff(): Argument #2 is not an array in /wp-includes/widgets.php on line 1160
    PHP Stack trace:
    PHP 1. {main}() /wp-admin/widgets.php:0
    PHP 2. retrieve_widgets() /wp-admin/widgets.php:124
    PHP 3. array_diff() /wp-includes/widgets.php:1160
    PHP Warning: Invalid argument supplied for foreach() in /wp-includes/widgets.php on line 1162
    PHP Stack trace:
    PHP 1. {main}() /wp-admin/widgets.php:0
    PHP 2. retrieve_widgets() /wp-admin/widgets.php:124
    PHP Warning: array_merge(): Argument #1 is not an array in /wp-includes/widgets.php on line 1170
    PHP Stack trace:
    PHP 1. {main}() /wp-admin/widgets.php:0
    PHP 2. retrieve_widgets() /wp-admin/widgets.php:124
    PHP 3. array_merge() /wp-includes/widgets.php:1170

    Additionally, check your JavaScript console at the Widgets screen (if needed, you may reference our KB article Using Google Chrome Developer Tools) and compare these:

    Please let us know how things go after passing along the information regarding these two issues (WP_DEBUG and console messages) to Avada’s support.

    Thank you.

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Pro widget not working’ is closed to new replies.