Help Desk

Page format issues creating or editing an event

  • Posts: 36 Topics: 14
    | Permalink

    Hi there, I added a child theme to my site and now when I go to create an event for the community calendar (not from the WP admin panel) the pages look out of format and filled with data at the bottom. When I go back to the parent theme, everything looks normal.

    Any suggestions?

    Thanks,
    Miguel

    Posts: 36 Topics: 14
    | Permalink

    Hi there, I’m sorry for my second note but this issue is really affecting our production site.
    Any suggestions as to what is happening?
    Thanks,
    Miguel

    Posts: 3271 Topics: 4
    | Permalink

    Hola Miguel!

    I’m sorry you are experiencing that issue. Let me help you with the troubleshooting.

    It seems like there might be some JavaScript/styles conflict or resources missing from that page. Could you please see if get any console errors when inspecting the page? Here’s an article on how you can do that > https://theeventscalendar.com/knowledgebase/using-google-chrome-developer-tools/

    When creating the child theme, you should follow the guidelines stated here > https://developer.wordpress.org/themes/advanced-topics/child-themes/. Please verify you are correctly enqueuing the styles and scripts in your child theme’s functions.php file.

    Let us know how it goes.

    Best,
    Victor

    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink

    Hola Victor, quick question. Is there a shortcode that I could paste in a page to create an event? I would like to test something over here.

    Thanks,
    Miguel

    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink

    Sure Miguel!

    Do let us know how it goes and if there is anything else we can do on our side to assist.

    Best,
    Victor

    Posts: 36 Topics: 14
    | Permalink

    Hola Victor,
    I can’t get the developer of the theme to do anything to fix the issue. He recommended to use another calendar plugin.
    This is very frustrating.
    Is there anything you guys can do on your side?
    Miguel

    Posts: 3271 Topics: 4
    | Permalink

    Hola Miguel!

    I’m really sorry to hear that. I can truly understand your frustration with this issue.

    I made a closer inspection in the child theme files and I could find the conflicting code that is causing the community submit form to break. It seems the jb_shortcode_unautop() function in the themes-shortcodes.php file located at /wp-content/themes/directory-4x/includes/ is being added to ‘the_content’ filter, causing the addition of <p> tags and </br> tags in the document, mixing them up with Javascript code, thus breaking it.

    By removing line 68 of that file

    add_filter( 'the_content', 'jb_shortcode_unautop',100 );

    I could make the form work correctly.

    I’m not really sure if removing that line can cause other issues with other parts of the theme, so I’d suggest you get in touch with the child theme authors to let them know about this and see if they can give you some insight about it.

    I hope you can get this issue solved. Let me know if there’s anything else we can help you with.

    Best,
    Victor

    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 36 Topics: 14
    | Permalink
    This reply has been marked as private.
    Posts: 3271 Topics: 4
    | Permalink

    Hola Miguel,

    I’m really sorry to hear you could not solve the problem with your current child theme. I appreciate you following up to let us know about it.

    As you marked this thread “Resolved” I’ll go ahead and close it, but don’t hesitate to open a new topic whenever needed. We are always here to help as much possible.

    Also, I noticed your site is in Spanish, so if you feel more comfortable reaching out to us in Spanish, then feel free to do so as my native language is Spanish.

    Good luck with your projects 🙂
    Victor

    | Permalink

The topic ‘Page format issues creating or editing an event’ is closed to new replies.