Help Desk

organizer-fields.php still not being used as front-end output in 4.4.2

  • Topics: 1
    | Permalink

    Hello,

    I am trying to remove a few of the fields from the create new organizer area on the front-end submit an event form and found that those organizer fields (phone, website, email) are being pulled from the admin facing view still instead of the organizer-fields.php. Was this never implemented? Or am I missing something as I would like to remove phone and website from that area on the front-end.

    Thank you

    Posts: 11239
    | Permalink

    Hi, Courtney.

    I was able to replicate this behavior. Here are the details of the bug report that I submitted to our developers:

    Organizers:

    • Directly editing /wp-content/plugins/the-events-calendar-community-events/src/views/community/modules/organizer-fields.php to remove the Organizer Phone and Website fields takes no effect.
    • Copying that file to¬†[your-active-theme]/tribe-events/community/modules/organizer-fields.php and making customizations in that file also has no effect.
    • Directly editing /wp-content/plugins/the-events-calendar/src/admin-views/create-organizer-fields.php does take effect on the front-end Community Events form

    Venues:

    • I did not try to replicate for Venues but that should be tested too.

    ===

    You stated “still not being used” but I couldn’t find a previous report of this issue in our internal bug tracker. Do you know what version of Community Events and/or The Events Calendar that you first noticed this behavior?

    ===

    I’ll mark this ticket as Pending Fix, which means this thread should receive a reply once the applicable fix has been released. I cannot guarantee when it will be fixed as it’s in the development team’s hands now. They need to assign it, code it, test it, and schedule it for release.

    I apologize for this issue and appreciate your understanding and patience.

    Posts: 11239
    | Permalink

    Hi again, Courtney.

    Could you please make sure all your Modern Tribe plugins (and WordPress core) are at their latest versions and then confirm if this bug is fixed?

    Please let me know what you find out.

    Thank you.

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘organizer-fields.php still not being used as front-end output in 4.4.2’ is closed to new replies.