Help Desk

Event Aggregator Not Working

  • Posts: 82 Topics: 30
    | Permalink

    Hey,

    The event aggregator has suddenly disappeared nearly all my scheduled import. The only ones showing I added today. And in the history tag, events I know I set as recurring are showing as one time and with red exclamation points. Please advise.

    Posts: 82 Topics: 30
    | Permalink

    Attaching image

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    I’m sorry you are experiencing that issue. Let me help you troubleshoot that.

    It sounds strange that your scheduled imports disappeared. Do you recall any plugin, theme or WordPress core update, or any major change in your site before the scheduled imports disappeared?

    Could you please hover over the red exclamation points and let us know what error messages you get?

    What happens if you re-schedule one of those imports again? Does it work? Let us know if you get any other errors.

    Also, please enable WP_DEBUG and WP_DEBUG_LOG. This will create a debug.log file inside the /wp-content directory.

    After that, try manually running some of your scheduled imports, so that in case there is an error, it will be saved into the debug.log file. Please share that log file with us so we can see if any problem from there.

    Thanks,
    Victor

    Posts: 82 Topics: 30
    | Permalink
    This reply has been marked as private.
    Posts: 82 Topics: 30
    | Permalink

    I also installed WP Fastest Cache Options

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    Thanks for coming back with the information I asked.

    I understand that you could run a a scheduled import, are you still able to see the scheduled import?

    You mentioned before that not all your scheduled imports have disappeared, were all your imports from a Facebook URL or other sources too? Could you please share a URL from one of the imports that disappeared?

    We’ve had a few other users reporting a glitch when trying to connect with the Facebook API, so if you still experience failed imports from Facebook, please try going to your wp-admin > Events > APIs and click Refresh your Connection to Facebook.

    Regarding the log file, could you please make a zip file and send it to us? You can also use a third party service like Google Drive or Dropbox to share it.

    Thanks,
    Victor

    Posts: 82 Topics: 30
    | Permalink
    This reply has been marked as private.
    Posts: 4404 Topics: 8
    | Permalink
    This reply has been marked as private.
    Posts: 4404 Topics: 8
    | Permalink
    This reply has been marked as private.
    Posts: 82 Topics: 30
    | Permalink

    How do I do that?

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    A database dump is just a backup of your site’s database. You can get one using your cPanel or asking your hosting provider to do so. Another option is to use a plugin like WP-DB-Backup > https://wordpress.org/plugins/wp-db-backup/

    Here is a guide on how you can make a backup of your database > https://codex.wordpress.org/Backing_Up_Your_Database

    After you get a copy of your database, please send it to us in a private reply. If the size of it is too large, you can use a third party service like Dropbox or Google Drive.

    Let me know if you have other questions.

    Thanks,
    Victor

    Posts: 82 Topics: 30
    | Permalink

    Download keeps timing out. My host is looking into it. Anything I can do in the mean time? The plugin keeps getting stick at 20%.

    Posts: 4404 Topics: 8
    | Permalink

    Does Event Aggregator gets stuck or is it the WP-DB-Backup plugin? Let me know if you experience a different issue with your imports.

    Posts: 82 Topics: 30
    | Permalink

    WP-DB-Backup plugin gets stuck

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle,

    I’m really sorry the plugin gets stuck.

    Having a closer inspection to your debug.log, I can see many fatal errors about reaching the memory limit for your site, so there is a chance this might relate to the backup plugin getting stuck.

    [22-Sep-2017 06:40:21 UTC] PHP Fatal error:  Allowed memory size of 268435456 bytes exhausted (tried to allocate 262209 bytes) in /home/yourfri1/public_html/nerdoutapp.com/wp-content/plugins/wp-smush-pro/lib/class-wp-smush.php on line 392

    You should check with your hosting provider to verify if they can spot a performance issue on your site.

    Let us know how it goes.

    Best,
    Victor

    Posts: 82 Topics: 30
    | Permalink

    They supposedly fixed that last week so I think we should be good there.

    Posts: 82 Topics: 30
    | Permalink
    This reply has been marked as private.
    Posts: 4404 Topics: 8
    | Permalink
    This reply has been marked as private.
    Posts: 82 Topics: 30
    | Permalink
    This reply has been marked as private.
    Posts: 4404 Topics: 8
    | Permalink
    This reply has been marked as private.
    Posts: 82 Topics: 30
    | Permalink

    The imports I created yesterday appear to be working. I’ll keep an eye on them.

    Posts: 82 Topics: 30
    | Permalink

    Got this error while trying to import this https://www.facebook.com/pg/MJCardsandComics/

    There was an error fetching the results from your import: Connection timed out while transferring the feed. If you are dealing with large feeds you may need to customize the tribe_aggregator_connection_timeout filter.

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    Thanks for keeping us posted about your imports.

    The error you are getting could relate to a slow connection, a large number of events to import or just a glitch that can sometimes occur. The import is basically taking longer than expected, thus reaching the time limit set to wait for the events to be fetched.

    If you bump into that error more often, please try adding the following code snippet into your active theme’s functions.php file:

    add_action( 'tribe_aggregator_connection_timeout', function(){ return 120; } );

    The above code will double to amount of time to wait for the import to arrive, thus reducing the chances to get the error. Let me know how this goes.

    As for the missing imports, I got in touch with the dev team and they will further look into this issue, for which I have created a report and link it to this thread. It may take us some time to get a resolution but I’ll make sure to keep you posted once we have an update.

    Just to gather more information about this, do you recall performing a certain action in your site before the scheduled imports disappeared? Perhaps installing or activating a new plugin?

    I apologise for the inconveniences and we’d appreciate your patience while we work on this.

    Best,
    Victor

    Posts: 82 Topics: 30
    | Permalink

    Just got this error while importing events.

    {“success”:false,”data”:{“message”:”A record already exists with these settings, click here to edit it<\/a>.”}}

    Yes, as previously mentioned, I installed WP Fastest Cache Options.

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    Thanks for following up with this.

    The error message you are getting might be because you are trying to schedule an import that is already created in your database, thus warning you about it. What happens if you click the “click here to edit” ? Are you able to edit that scheduled import and then save it? Please let me know.

    I tried running some tests with scheduled imports and WP Fastest Cache, but I could not replicate the issue myself. Could you please send me a screenshot of the WP Fastest Cache Options so I can try to reproduce your issue? This will help us determine if there is a conflict with the WP Fastest Cache plugin.

    Thanks,
    Victor

    Posts: 82 Topics: 30
    | Permalink
    This reply has been marked as private.
    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    Thanks for sending over the screenshots.

    I made several tests with the WP Fastest Cache options you sent but unfortunately I could not reproduce the missing imports.

    Going back to one of your previous replies, you mentioned to have installed and activated these plugins > https://premium.wpmudev.org/. Could you please share a copy of those plugins you installed (in a private reply) and if you performed a specific action before your imports disappeared? We’ll try to run some tests with them to see if we can find any conflicts.

    Thanks,
    Victor

    Posts: 4404 Topics: 8
    | Permalink

    Hi Michelle!

    My apologies for the delay in getting back to you.

    After further investigation, we could not reproduce this issue on our end.

    There is no part of our code where we set the ping_status to closed. The fact that you have reported this happening on a specific date and not anymore after that makes us think this might have been caused by a third-party plugin.

    Do you know if any of the plugins you have installed deals with “ping_status” or, as commonly known, discussion settings? This could have triggered the scheduled imports records changing their ping_status in the database somehow.

    Please let us know about it so we can dig a little deeper into this issue and see if we can come up with a workaround for it.

    Thanks,
    Victor

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Event Aggregator Not Working’ is closed to new replies.