Help Desk

Caption on first image appearing for all of them

  • Posts: 6 Topics: 3
    | Permalink

    Right now I’m using a slider to share the images. Each image has a new caption but only the first image caption is showing for all of them.

    Also, is there a way to make the images change without a new site load? Like every 10 seconds, the image goes to the next one?

    Posts: 17417 Topics: 14 Answers: 973
    | Permalink

    I’m sorry to hear that, Meghan.

    Is this slider provided by a different company and can you point me to an example (I did browse some pages on your site but couldn’t locate an example of the problem)?

    Also, is there a way to make the images change without a new site load? Like every 10 seconds, the image goes to the next one?

    This sort of question (and in fact your initial question) might be better directed to the author of the slider.

    If it’s a plugin you installed, perhaps they’ll have a support forum or helpdesk of their own. Or, if it is part of your theme, then your theme author may be able to assist further.

    Since it’s not something we provide, though, I’m afraid there’s not a huge amount of direct assistance we can provide for this one.

    Posts: 6 Topics: 3
    | Permalink

    This question is about the Image Widget Plus which is why it is on the Image Plus support forum. Getting support is part of purchasing a license. The upgrade has flaws that I am trying to fix or notify the developers of.

    Posts: 17417 Topics: 14 Answers: 973
    | Permalink

    I do apologize, Meghan: I came to this from a different forum and totally missed that you had posted in the Image Widget Plus forum.

    Each image has a new caption but only the first image caption is showing for all of them.

    Hmm, that’s not my experience when I test this out for myself locally. I visited your site to get a sense of the problem as it is there and located an instance of the widget on your homepage – but the problem doesn’t seem to impact that particular instance.

    Can you confirm where I should look to see the problem?

    Also, is there a way to make the images change without a new site load? Like every 10 seconds, the image goes to the next one?

    It’s not an option that’s built in, I’m afraid. Seems like a nice idea, though. Might this plugin help to get you started? It can be installed and activated like any other plugin and should add autorotation capabilities to your existing Image Widget Plus instances.

    It is really just a starting point you might build on yourself further if needed — you are also more than welcome to propose this as a feature for inclusion in a future release if you like.

    UserVoice – submit your suggestions here!

    Thanks 🙂

    Posts: 6 Topics: 3
    | Permalink

    https://jamonkey.com
    It is the enter to win section in the sidebar.

    The first image has a title that is showing for all images. Even if I write a new title for each image only the first image title shows.

    Posts: 17417 Topics: 14 Answers: 973
    | Permalink

    I see that now, though I wasn’t initially able to and I can’t replicate it every time I visit, either. Here’s a screenshot where the caption successfully changed (which is also what happened the first time I checked your site):

    Meghan, there are many and varied errors I can see when I open my browser console during a visit to your site. Since I can’t replicate this locally and we aren’t seeing similar reports from other users it does rather look like a conflict of some kind.

    theeventscalendar.com/knowledgebase/testing-for-conflicts

    Would you be able to give the above steps a shot? Or, alternatively, if it is not possible to do this on your live site how about installing a fresh copy of WordPress in a sub-directory (ie, example.com/testsite) giving you a safe place to test things out?

    Start with just a default theme and install only our plugin – do you see the same problem there? If you do not, that further bears out the idea that a conflict is at play on your live site.

    Let me know if you’re able to test via either approach and what you find.

    Thanks for your patience so far!

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Caption on first image appearing for all of them’ is closed to new replies.