Help Desk

500 Error When Adding or Editing Recurring Events

  • Posts: 14 Topics: 6
    | Permalink

    When adding a new recurring event or updating an existing recurring event, receive a 500 error. Single events works fine still.

    Posts: 14 Topics: 6
    | Permalink

    I also tried to reset permalinks, but that did not resolve it.

    Posts: 1485 Topics: 1
    | Permalink

    Hey Shay,

    Thank you for reaching out to us! I’m so sorry to hear that you are having problems to add/edit your recurring events: let me help you to solve this!

    The 500 Internal Server Error is a very general HTTP status code that means something has gone wrong on your website’s server, but it could not be more specific on what the exact problem is. This status code is usually associated with a PHP Fatal Error, so to identify the cause of this issue, I would recommend you to temporarily enable WP_DEBUG and WP_DEBUG_LOG and share with us any messages you see while creating and editing your recurring events. All WP_DEBUG messages will be stored in a debug.log file in /wp-content/debug.log.

    Please send us your test results and we will be glad to help you with the next steps!

    Cheers,

    Patricia

    Posts: 14 Topics: 6
    | Permalink

    No debug messages were shown and no log entries were created. I just get redirected to wp-admin/post.php when updating or adding a recurring event. Single events still work fine.

    Posts: 1485 Topics: 1
    | Permalink

    Hi Shay,

    This sounds like a server limitation as you are unable to log and display PHP errors. I’ve just reviewed your system info and you don’t have a value for PHP display_errors (it is currently blank):

    PHP
    display_errors =
    log_errors = 1

    At this point I would recommend you to contact your hosting provider and ask them to take a look at your php.ini file and make sure that you are actually able to display and log errors in your server.

    If you have any news regarding your error log or have any other questions in the meantime, please let me know!

    Best regards,

    Patricia

    Posts: 14 Topics: 6
    | Permalink

    Was able to get messages to display and receive this:

    Allowed memory size of 536870912 bytes exhausted (tried to allocate 82 bytes) in /home/offixo6/public_html/thalia/wp-content/plugins/events-calendar-pro/src/Tribe/Recurrence.php on line 93

    I tried increasing the memory limit to 512M, 1024M, and 1G. None of those worked.

    Posts: 14 Topics: 6
    | Permalink

    I also tried changing limit to 4096M. When I do that, I receive this message: “Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case.”

    And then page then redirects to https://thaliaumc.org/wp-admin/post.php (404 Error)

    Posts: 1485 Topics: 1
    | Permalink

    Hi Shay,

    Thanks for sharing your test results with us! I’m sorry to hear about this PHP Memory exhaustion error you are experiencing. As a first step, I would recommend you to install and activate Server IP & Memory Usage Display in your site. This plugin will display the memory limit, current memory usage and WordPress Memory Limit in the admin footer. It will help you to identify if your site is already nearly reaching PHP memory limit before triggering the action that throws the PHP Fatal error.

    I would also recommend you to run a Conflicts Test to verify if a combination of plugins is causing the high memory usage. You can start the test by temporarily deactivating all of your plugins (except Modern Tribe plugins) and changing your theme to another one like Twenty Seventeen and let us know if the problem is solved after that (don’t forget to backup your database before changing anything).

    I’ve seen in the past websites with a similar issue as yours and enabling caching was the solution to their problems: this happens because once a caching method is enabled, the number of requests that directly hits your server/PHP is drastically reduced. If you don’t have a caching plugin enabled in your site yet, I would recommend you to install one, or ask your hosting provider to enable server side caching as well.

    I hope this helps you to get started.

    If you have any other questions at all please feel free to let me know and I’d be happy to help as best I can!

    Cheers,

    Patricia

    Posts: 14 Topics: 6
    | Permalink

    I was never able to get this fixed. I cloned the theme on a new install and added the same plugins one by one. That seemed to resolve the problem. Thanks for trying though!

    Posts: 1485 Topics: 1
    | Permalink

    Hi Shay,

    I’m glad to hear that everything is working as expected in your new WP install! If you need an assistance again or have other concerns, please feel free to open up a new thread, we’ll be more than happy to help you!

    Regards,

    Patricia

    | Permalink

The topic ‘500 Error When Adding or Editing Recurring Events’ is closed to new replies.