Widget not displaying

Home Forums Calendar Products Events Calendar PRO Widget not displaying

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #1632359
    Fran
    Participant

    I added an upcoming events widget to my homepage in Beaver Builder and styled it using MicroTHemer. Everything looked fine yesterday, and today nothing is showing up, not even the title when I deselected the option to only show it if there are events. There are lots of upcoming events.

    https://www.screencast.com/t/uYt428o8

    #1632361
    Fran
    Participant

    This reply is private.

    #1634671
    Courtney
    Keymaster

    Hey Fran

    Can help me narrow this down.

    Are you using a child theme as a derivative of Beaver Themer?

    Can you share a screenshot of how you have added the widget to the home page?

    I am wanting to narrow down if this is a Themer or Builder issue.

    Does the widget insert and display well on another page either in the sidebar or within the post/page content? https://theeventscalendar.com/knowledgebase/pro-widget-shortcodes/#event-list-shortcode

    Can you revert first to disabling all plugins except ours and Beaver Builder and see if that still displays the widget? And if that still doesn’t work, please also deactivate Builder and use a default theme, such as Twenty Seventeen https://wordpress.org/themes/twentyseventeen/.

    I’m familiar with both plugins you mentioned using. Looking forward to getting this resolved with you.

    Thanks
    Courtney ๐Ÿ™‚

    #1634824
    Fran
    Participant

    Hey Courtney,

    Thanks for your help!

    To answer your questions…

    I am using the Astra Theme with a Child theme, Beaver Builder and Beaver
    Themer. All up-to-date.

    I added the widget to the homepage using the widget that shows at the top
    of this screenshot: https://www.screencast.com/t/JJNfkONjSn

    I think I initially added it using [tribe_events_list], but then it turned
    into that widget – is that possible? Because when I tried to recreate it by
    adding the “events list” widget from the WordPress widgets list in BB, I
    got the module at the bottom of that screenshot (which has more options),
    and that one works. Both just say “widget” at the top. If I save the module
    from the first one, and add it to another page (see the user-login page), it
    doesn’t work there either. Adding the “events list” widget to the sidebar
    or the content works (although the formatting is different).

    I also tried adding the saved module using bb shortcode, and that doesn’t
    work either ([fl_builder_insert_layout slug=”Upcoming-events-widget”])

    I deactivated all of the plugins except essentials and it still didn’t
    work. I changed the theme to 2017 and it still didn’t work.

    I hope I’ve given you enough information to go on. I suppose I can just use
    the other widget, but I prefer not to have those blocks with the day date
    to the left (I suppose I can remove them with CSS).

    Thanks again, Courtney!

    #1635701
    Fran
    Participant

    This reply is private.

    #1637776
    Courtney
    Keymaster

    This reply is private.

    #1637801
    Courtney
    Keymaster

    Hey Fran

    Can you share a link to see the widget displayed?

    All shortcodes on https://theeventscalendar.com/knowledgebase/pro-widget-shortcodes/ will display as a widget-like layout, even if inserted into a wider area. That would include [tribe_events_list]

    Full view shortcodes can be found on https://theeventscalendar.com/knowledgebase/embedding-calendar-views-tribe_events-shortcode/.

    Can you also see that on your staging site, if you’ve added and activated your license key at Events ยป Settings ยป Licenses?

    Thanks
    Courtney ๐Ÿ™‚

    #1641776
    Fran
    Participant

    Hey Courtney,
    I tried a different shortcode and used CSS to hide the big block numbers to the left, but when I try to center the text it’s centering, but off-centered within the column, and I can’t seem to find the right targeting, and I’m wondering if it’s because I used display:none for the block numbers. Is there another way to turn off those numbers, like an argument? I looked on the pages you recommended but didn’t see anything. It’s on the homepage of my site, which is password protected, but you can find the credentials in a previous private email I sent.

    Thanks,
    Fran

    #1643887
    Courtney
    Keymaster

    Hey Fran

    My apologies on the delayed response here. We’ve been migrating to a new help desk platform, but I will finish out this thread with you here.

    I’m not sure what block numbers you might be seeing. It wouldn’t be generated by The Events Calendar related plugins, but perhaps from Beaver Builder.

    Please share a screenshot and a link to the exact location I can see the areas you are still working out.

    Thanks
    Courtney ๐Ÿ™‚

    #1645210
    Fran
    Participant

    This reply is private.

    #1645211
    Fran
    Participant

    This reply is private.

    #1646652
    Courtney
    Keymaster

    Hey there Fran

    Ah now I follow.ย  I believe this is an issue in how Beaver Themer works with our plugin. If you have that area set to fill the width, it is stretching things out.ย  Can you flag the issue with their team too?ย  I haven’t been able to reproduce this with any default themes or gotten reports with other themes either.

    Can you link me to the exact page where the widget appears?ย  I’ll see if I can find a CSS method to stop the width from stretching out.

    Thanks
    Courtney ๐Ÿ™‚

    #1646720
    Fran
    Participant

    This reply is private.

    #1647556
    Courtney
    Keymaster

    This reply is private.

    #1647584
    Fran
    Participant

    This reply is private.

Viewing 15 posts - 1 through 15 (of 17 total)
  • The topic ‘Widget not displaying’ is closed to new replies.