Help Desk

Unable to translate "Upcoming Events" title

  • Posts: 6 Topics: 4
    | Permalink

    Hi there,

    I use The Events Calendar for events on my website. I had been told previously on another support thread that the plugin can be translated using WPML so I purchased it to make my website bilingual. I was able to translate all the strings related to the plugin without any trouble, however, the title of the page “Événements à venir” (French for “Upcoming events”) is nowhere to be found for translation.

    I requested support from WPML and they scanned all the pages, widgets and plugins to try to find the string related to the title, without success. Therefor, they asked me to ask the following so they can help me :

    “I checked your site but I had no idea where this string is from.
    * Installed Adminer plugin, checked the database, there is no string “Événements à venir”.
    * Checked the file \eristik\wp-content\plugins\the-events-calendar\lang\the-events-calendar-fr_FR.po , there is no exact string “Événements à venir”.

    Here’s the direct link to the events page (English version) on the website : https://www.eristik.com/events/?lang=en

    Thank you

    Now the question should come to the plugin author, please ask them where the plugin get this string? Where is it set?

    If we don’t know where it’s from, we can not help you translate it.”

    Posts: 6978 Topics: 2
    | Permalink

    Hi Sarah,

    Thanks for going Pro and welcome to the forums!

    I’m sorry you are experiencing this problem. I’ll try to help you with this.

    As a first could you please share with me your system information based on this guide:
    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

    What is the main language of your site? The setting under Settings > General > Site Language

    In what language was your WordPress site originally set up? In French or in English?

    Waiting for your reply.
    Cheers,
    Andras

    Posts: 6 Topics: 4
    | Permalink

    Hi Andras,

    Here’s the system information :

    [Removed by admin]

    The main language of the website is French. It was set originally in French.

    Thank you

    • This reply was modified 3 years, 4 months ago by  Andras.
    Posts: 6978 Topics: 2
    | Permalink

    Hello again Sarah,

    Thanks for submitting your system information. I see there that the main plugin, The Events Calendar is not installed, is that right?

    I also see that you are using WooTickets, which is an older plugin. WooTickets has been replaced by Event Tickets Plus, which covers all the functionalities. I believe you should be able to upgrade for free. You can download Event Tickets Plus from your account at theeventscalendar.com

    I strongly suggest you to upgrade, as we will be stopping support for WooTickets pretty soon.

    As for the title translation, please allow me a bit more time to investigate. I’ll get back to you soon.

    Cheers,
    Andras

     

    Posts: 6978 Topics: 2
    | Permalink

    I also realized now that your WPML plugin set is also out of date. I would also recommend to update that one and any other plugins that show an available update. This is important for both security and compatibility reasons.

    I’ll keep investigating, meanwhile if you could get back to me when the updates are done, and if that changes anything, that would be great.

    Cheers,
    Andras

    Posts: 6 Topics: 4
    | Permalink

    Thanks Andras. So if I understand correctly, I should remove WooTickets from my plugins and only install the Event Tickets Plus instead?

    I will go ahead and install all the updates and get back to you.

    Thank you

    Posts: 6531 Topics: 11
    | Permalink

    Hi there Sarah,

    Andras will be out so I’ll continue to help you on this issue!

    I should remove WooTickets from my plugins and only install the Event Tickets Plus instead?

    Yes, deactivate WooTickets (you can remove it after you test the update) and install (and activate) Event Tickets and Event Tickets Plus.

    Regarding the string, I think this is the one you are looking for → Upcoming %s, which translation currently is Prochains %s. Please note that the %s part is replaced by the Events translation.

    Please let me know if this is what you were looking for,
    Best,
    Nico

    Posts: 6 Topics: 4
    | Permalink

    Hi Nico,

    I installed Event Tickets Plus. However, a message displaying in the admin panel is asking me to install Event Tickets first to be able to configure Event Tickets Plus.

    When I look in my “Downloads” in my account, I only have Event Tickets Plus and Woocommerce Tickets to download.

    Any idea on what to do?

    Thanks

    Posts: 6531 Topics: 11
    | Permalink

    Thanks for the follow-up Sarah!

    Sorry if I wasn’t clear enough, Event Tickets Plus works as an add-on for Event Tickets. Just like Events Calendar PRO and The Events Calendar. So yes, you’ll need to install Event Tickets which you can find here → wordpress.org/plugins/event-tickets/

    Best,
    Nico

    Posts: 65
    | Permalink

    This topic has not been active for quite some time and will now be closed.

    If you still need assistance please simply open a new topic (linking to this one if necessary)
    and one of the team will be only too happy to help.