Help Desk

Trouble after moving site from "siteinprogress" to live

  • Topics: 1
    | Permalink

    I set up the events calendar and Community Events. I set up multiple events users and they were happily entering their events. When we moved the website to its current URL and went live problems started.

    1) There was no longer an events contributor category in users.
    2) Some events showed up as duplicates on the calendar and when I moved one of them to the trash they continued to be listed on the calendar.

    Posts: 1180 Topics: 1
    | Permalink

    Hello faith,

    Sorry to hear about your difficulties!

    Migrations can be finicky, but can be very simple if done properly. Typically for my migrations I do an entire site sql dump, search/replace the entire file for the old/new urls and then import the sql to the next db. Otherwise it is easy to miss important fields.

    Could I get a detailed description of your site migration? Did you use a plugin, or some other mechanism?

     

    Can you provide a link (or expected link) for this piece? By category do you mean ‘role’?

    There was no longer an events contributor category in users.

     

    This blog post might explain your duplicate problem. If you use the included duplicate cleanup plugin, you might be able to clean up your events that way.

    Some events showed up as duplicates on the calendar and when I moved one of them to the trash they continued to be listed on the calendar.

     

    Please make sure you have a recent backup of your site before you start! I’m assuming nothing bad will happen, but better to be safe than sorry.

    Does this make sense? Let me know if this doesn’t work for you.

    Cheers!

    – Casey Driscoll

    Posts: 1180 Topics: 1
    | Permalink

    Hello faith,

    We typically close threads if there is no activity after two weeks. Feel free to create a new thread and reference this one to save you time.

    Cheers!

    – Casey Driscoll