Help Desk

Translation

  • Posts: 24 Topics: 17
    | Permalink

    I can’t get these 3 translations to work:

    On the calender in month view:
    search
    There were no results found.

    In the list of users events:
    Edit
    Delete image

    Please help me, Thanks

    Posts: 24 Topics: 17
    | Permalink

    Sorry… 4 translations

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Hi alfemand,

    Thanks for posting. Sometimes translations are outdated, which results in English showing through. If you can tell me what translation you’re using, I can tell you when it was last updated. I’d love to have you do the update, and I can give you a free license for the plugin in exchange!

    Another factor is that some elements of the calendar are translated by WordPress itself and not via our plugin translations. This means that if you do not have the WordPress translation files loaded for your language you will see some untranslated words in your calendar, even with your language set in wp-config. To fix this, you’ll need to download and install WordPress for your language. Then the Day View (and other Views) should be fully translated.

    Best,

    Leah

    Posts: 24 Topics: 17
    | Permalink

    It’s the po file from version Version 3.3 , so it’s not that old

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Hi alfemand,

    I’m sorry if I wasn’t clearer. Even if the .po file itself is included in The Events Calendar 3.3, it may be an old translation. For example, our Polish translation hasn’t been worked on since version 3.0, so there are strings missing that were added in later versions.

    If you let me know which language you are using that will help me tell you how old the translation is. But it sounds like it needs an update. Are you interested in working on that for us? You can read our Getting Started post for instructions and files.

    Best,

    Leah

    Posts: 24 Topics: 17
    | Permalink

    Hi Leah it’s Danish Language.
    The link you posted dosen’t work.

    I would have no problem working on the file for you, if you could help me by taking a quick peak at one problem i got, and lead me in the right direction.
    If i enable the Events calender setting, to include events as post on my frontpage, all thumbnail of event post’s and my normal post’s stop showing

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Hi alfemand,

    Hi Leah it’s Danish Language.

    It looks like our Danish (da_DK) translation hasn’t been updated since Events 3.0, so there are quite a few missing strings there. It would be great to have you update it. And we’ll give you a free license in exchange for your work!

    The link you posted dosen’t work.

    Sorry about that! It’s fixed now. Check out that page for the instructions and files you’ll need to update the translation.

    I would have no problem working on the file for you, if you could help me by taking a quick peak at one problem i got, and lead me in the right direction.
    If i enable the Events calender setting, to include events as post on my frontpage, all thumbnail of event post’s and my normal post’s stop showing

    We’d be happy to help you out, but you’ll need to post in our regular PRO Forum for support. They’ll be able to help you out there.

    Best,
    Leah

    Posts: 24 Topics: 17
    | Permalink

    The link https://theeventscalendar.com/support/forums/topic/translations-getting-started/tri.be/support/forums/topic/translations-master-list/ is also dead.

    There is no help in the pro forum, since my problem is a theme conflict.
    I think that is somewhat bad, since i spent 130$ on your plugins and your standard response is: If it works with the default 2013 theme there is no support.
    Nobody uses the default 2013 theme, so i think you could be a little more user friendly, and at least take a quick look and see if there possible could be a quick fix

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Hi alfemand,

    Thanks for pointing out about the link- I’ve fixed that one as well.

    I’m sorry you are having trouble with a theme conflict. As noted in our forum post, we work hard to make our plugin(s) compatible with the majority of themes, but due to the variation out there we cannot guarantee 100% compatibility with them all. It looks like Casey was able to help you narrow down the particular problem, and it is something on the theme’s side. I recommend that you get in touch with the theme’s developer to see if they can help you resolve the query conflict.

    I hope the above will help lead you to a solution so you can continue to use both your theme and our plugins. However, if you feel that you need to find a solution, we can look into providing a refund for you. If you’d like to pursue that option, please send an email referencing this thread and including your order receipts to pro @ tri.be.

    Best,

    Leah

    Posts: 24 Topics: 17
    | Permalink

    I have fixed my theme conflict but still having issues with the translation of the 4 strings.

    I have merged your latest pot file with my po files and one of the strings was in there “There where no results found” But it still dosen’t work.

    Please put these strings into your plugin:
    search = Søg
    There were no results found = Der blev ikke fundet nogen resultater
    Edit = Rediger
    Delete image = Slet billede

    | Permalink

    I can help you to translate in Italian.

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Antonio47 – please post a new thread and let me know what plugin(s) you are interested in translating to Italian.

    alfemand – thank you for the update. I have a number of threads to get through, but I will take a look at those strings as soon as possible.

     

    ~Leah

    Posts: 3443 Topics: 13 Answers: 199
    | Permalink

    Hi alfemand,

    Thanks for your patience. You said that you updated the da_DK .po file with the latest .pot file. But it’s still not working after you translated the new lines? If you could upload that file for me, I can take a look and try to figure out what’s wrong.

    Can you also please send me a screenshot of the 4 strings you mentioned, so I can see exactly where they are in the plugin or your dashboard? That will also help me pinpoint the issue.

    Thank you,

    Leah