Help Desk

recurring events showing up every day!

  • Posts: 41 Topics: 24
    | Permalink

    I have a weekly set of events, all of the events I put in show up on every single day. I only have monday events on monday, tues on tues, etc. When I look at the recurrence, it is right. In the calendar view it is right, in the widget, all events are on all days. help please!!!

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hey Adam. I can try to help you out with this; are you using the 2.0.1 code base, or just 2.0? If the latter I would suggest updating. If it still persists at that point, can you send me a link to the site so I can take a look?

    Posts: 41 Topics: 24
    | Permalink

    where do I DL the update?

    Posts: 6
    | Permalink

    I JUST purchased Pro today, so mods please delete if this is not helpful, but I was getting some bizarre recurring behavior when I began setting up (what should be) weekly events – some recurred every day, some two or three days out of the week. However, when I switched from using End ON to End AFTER it seemed to fixt the problem.

    Again, haven’t been using it long enough to know if this is a fix or a fluke but thought I’d share.

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hey Adam. You should be prompted to update within the plugins list on the backend of your site.

    Ginny: thanks for reporting that…it’s a new issue best I can tell. Can you provide some steps to recreate? i’ll see what I can do to recreate/get fixed for a future release.

    Posts: 6
    | Permalink

    I literally installed the plugin and created an event, Sunday worship, from 9-10 a.m. recurring weekly until a Sunday I chose from the calendar in 2014. When I viewed the Event calendar grid, Sunday worship occurred every day of the week, every week.

    I then created a new event to recur weekly on Wednesdays, with recurrence ending on a Wednesday 3 weeks from the start date. When I viewed the grid, that even recurred every Monday, Tuesday and Wednesday for three weeks.

    I’ve since been using End After a number of weeks, and everything seems to be working perfectly.

    In both cases I double checked to make sure that my *event* start date and end date were the same day (thinking maybe I’d inadvertently set up a multi-day event), but they were both set up correctly for one-hour events on a single day.

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hi Ginny. Thanks for the follow-up; weirdly I just tested both of these and was unable to recreate either. Are you on 2.0.1, or just 2.0?

    If so – can you check whether this is a conflict with either another plugin (by deactivating those you’ve got active one at a time), or with theme (tested by reverting to 2011 WP theme)? Let me know if after doing all that you’re still having issues…if so, might need an admin account to test myself. But let’s try this first. Also, please make sure you’ve gone into your permalinks page and saved (no need to make changes; just save). Thanks in advance!