Help Desk

reCaptcha / Anti Spam Check Issues

  • Posts: 2 Topics: 1
    | Permalink

    Hey there,

    We’re having issues with our front end community form where the reCaptcha is sometimes not showing and users are not able submit events. This seems to be sporadic and works differently in different browsers. For example, I see it every time in Safari, but I don’t see it in Chrome hardly at all – just a blank space where the captcha should be showing.

    Please help, and thanks!

    Posts: 1429 Topics: 1
    | Permalink

    Hi Gail,

    Thank you for reaching out to us!

    This is odd: could you please send us the link to your community events submission form so we can take a look? I’ve tried the default path (events/community/add) and it didn’t work (the default rewrite slug was probably changed).

    Thanks!

    Patricia

    Posts: 2 Topics: 1
    | Permalink

    Hey Patricia,

    Sorry about that, here you go: http://www.bbu.org/calendar/community/add/

    Posts: 1429 Topics: 1
    | Permalink

    Thanks Gail!

    I’ve ran some tests in my own WordPress install and can confirm that this is not an issue that I can replicate from here, although it is definitely happening in your site.

    This is the js error I’ve found in your community events submission form:

    Uncaught Error: Syntax error, unrecognized expression: [href=#]

    After some research I’ve found out that this issue could be associated with a jQuery conflict/version. To get started, I would recommend you to temporarily change your theme to another one like Twenty Seventeen and let me know if the JavaScript error is solved after that (don’t forget to backup your database before changing anything). If the jQuery error is gone and reCaptcha works as expected after this change, I would recommend you to contact your theme developer so they can take a look.

    I hope this helps! If you have any other questions ain the meantime, please feel free to let me know and I’d be happy to help as best I can!

    Cheers,

    Patricia

    Posts: 2 Topics: 1
    | Permalink

    Hey Patricia,

    Thanks for the reply! I switched to 2017 and indeed it works fine. I tracked down the js error and found it was related to our outdated version of the Avada theme and have applied a hack patch to fix it for now. You can consider the issue resolved.

    Thanks!

    Posts: 1429 Topics: 1
    | Permalink

    Hi Gail,

    You are welcome 🙂 I’m glad to hear that you were able to find the source of the conflict!

    If you have any other questions, please feel free to open a new thread and we will be happy to help!

    Cheers,

    Patricia

    | Permalink

The topic ‘reCaptcha / Anti Spam Check Issues’ is closed to new replies.