Help Desk

Problem: Country list not applying translation

  • Posts: 3 Topics: 3
    | Permalink

    Hi,

    I’m currently using Events Calendar with PRO version with 996 events.

    After update to latest version, i’ve noticed that all country names loosed its translation and disassociated from venues because now they are in english.

    Before, the country names were in portuguese. I took a look at translation files, and there they are already translated.

    I took a look at function build_country_array() and changed the name of the country there to portuguese to see what happens and after change the string from english to portuguese, the country became associated again to the venue.

    Any ideas?

    Thank you

    Posts: 4722
    | Permalink

    Hi Marcelo,

    Thanks so much for reaching out!

    To start off, take a look at the following articles, which may be able to point you in the right direction with your translations:

    Let me know if that helps!

     

    Thanks,

    Jaime

    Posts: 3 Topics: 3
    | Permalink

    Hey Jaime, thank you for your reply.

    As you can see in the first screenshot, the labels in the metabox are translated to portuguese. The problem is that countries dropdown values are not being translated and they are inside the same translation file.

    I’ve tested the translation file by changing the label translation to something else to see if it was working and it was.

    For some reason, only the country names are not being translated.

    Posts: 4722
    | Permalink

    Hi Marcelo,

    Okay I see what you mean.  This is actually an issue that we are aware of currently.

    In the meantime, you might want to try using a shortcode based approach as explained here: https://wpml.org/forums/topic/conditional-language-shortcode/

    Let me know how that goes!

     

    Thanks,

    Jaime

    Posts: 3 Topics: 3
    | Permalink

    The latest update seems to resolve the issue. Thank you!

    Posts: 4722
    | Permalink

    Glad we could help, you are welcome back in our support forums any time!

    Since you marked this thread as Resolved, I am going to close this thread.

    Have a great week!

    | Permalink

The topic ‘Problem: Country list not applying translation’ is closed to new replies.