Help Desk

PRO shortcodes not showing event in month view

  • Posts: 9 Topics: 3
    | Permalink

    I just purchased the PRO plugin this afternoon as I am needing to embed shortcodes in a page. Unfortunately, I’m finding the multi-day event is not showing in the month view; the only indication that something should be there is an unusually long (but empty) box for the date. When I hover over each of the event dates, the hover data does show. When I switch to list view, all of the event particulars show.

    I’ve edited the event down to just a few hours within a single day to see if the issue is somehow related to the multi-day event, but find it does the same thing there as well.

    Upon deactivating each plugin, I found no change in the calendar rendering, but when I deactivated the theme / child theme (Genesis with the Wellness Pro child theme), the calendar then showed event details in each day.

    Posts: 2010
    | Permalink

    Hi there,

    Thanks for emailing support and sorry you are having issues. So it sounds like there is a conflict between the theme and our plugin.

    Can you send me a link to your site so I can see this firsthand? I’m a visual person, and I can often be more helpful in giving solutions to problems I can see and interact with.

    Thanks,
    Brendan

    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 2010
    | Permalink
    This reply has been marked as private.
    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 2010
    | Permalink
    This reply has been marked as private.
    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 2010
    | Permalink
    This reply has been marked as private.
    Posts: 9 Topics: 3
    | Permalink

    Brendan, when I deactivate everything except your plugins and use the default 2017 theme over the Genesis framework, the calendar works fine. However, once I activate the Wellness Pro child theme, the month view calendar blocks that should have content in them are again oversized and showing blank. :\

    Posts: 9 Topics: 3
    | Permalink

    Brendan, I think I may’ve found (and hopefully fixed) the issue. Inspecting the element on one of the oversized but empty calendar boxes more closely, I decided to tweak and reduce the padding here:

    `/* Entries
    ——————————————— */

    .entry {
    background-color: #fff;
    margin-bottom: 40px;
    padding: 70px 80px;
    }`

    Once I took the padding down to 10px (the first and only change I tried), the calendar dates showed in a normal size and with content.

    Posts: 2010
    | Permalink

    Hi there,

    Thats awesome and modifying the css is definitely great as long as its in the child theme. Also, thanks for posting solution for others in case they run into this issue.

    Brendan

    Posts: 7
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘PRO shortcodes not showing event in month view’ is closed to new replies.