Help Desk

Past Events stops at page 2

  • Posts: 2500
    | Permalink

    Hi there,

    Can you also try testing for conflicts with your theme and other plugins? If you would prefer not to do this on your live site, WP Staging will let you create a quick copy of your live site that you can use for testing. Let me know what you find!

    Thanks,
    Brendan

    Posts: 28 Topics: 10
    | Permalink

    Brendan,

    Thanks for your reply. I’ve now checked every plugin on the site – and
    also tried the default 2017 theme. The error still occurs!

    Interestingly, the back pages of events are there – you can go to their
    URL directly (e.g.,
    https://bsia.staging.wpengine.com/events/?action=tribe_photo&tribe_paged=3&tribe_event_display=past
    )

    It’s just when you hit the “Previous Events” button the second time that
    it somehow doesn’t trigger the second page of past events to come up
    even though the URL changes.

    hope that helps,

    Posts: 2500
    | Permalink

    Hi there,

    So looking at the console. I can see no javascript errors but I do see its not working. Now, can you enable debug mode and then go to that page and see if there are any errors and send them here?

    https://codex.wordpress.org/WP_DEBUG

    Thanks,
    Brendan

    Posts: 28 Topics: 10
    | Permalink

    Hello again,

    If it’s helpful – here’s a copy of the site will all plugins (except The
    Events Calendar, The Events Calendar Pro and Events Tickets) turned off,
    and the theme switched to 2017. The same second-page-of-events-archive
    error seems to occur…

    Posts: 2500
    | Permalink

    Hi Jacob,

    I am not seeing anything attached to your last message. Were you trying to add something?

    Thanks,
    Brendan

    Posts: 28 Topics: 10
    | Permalink

    My apologies. Here’s the URL for the staging site with no other plugins and the 2017 theme: https://bsia.staging.wpengine.com/events/

    It’s a similar issue here – but sometimes the button to past events doesn’t appear. If I go back and try again, it’s often there. But then it doesn’t advance to the second page of past events…

    Hope that helps. I’ll try and turn on DEBUG as well.

    Posts: 28 Topics: 10
    | Permalink

    Also – I have turned on WP_DEBUG and don’t see any errors in the log straight away…

    cheers,
    Jacob

    Posts: 2500
    | Permalink

    Hi Jacob,

    So we tested this out on our local install with the same PHP version and are getting this issue as well. I am created a bug ticket for our developers to investigate. Going to mark this ticket as “Pending Fix” so when its fixed, they can reach out to you.

    Thanks,
    Brendan

    Posts: 28 Topics: 10
    | Permalink

    Sounds good. Thanks for letting me know.

    Posts: 2500
    | Permalink

    Thanks Jacob, we will keep you posted.

    Posts: 28 Topics: 10
    | Permalink

    It looks like the most recent update resolved this. Thanks!

    Posts: 28 Topics: 10
    | Permalink

    One issue popped up with the Previous Events. We are getting multiple pages of past events, but they are not in chronological order, they seem to be listed fairly arbitrarily. Any thought on how to fix this?

    Posts: 2500
    | Permalink

    Hi Jacob,

    This seems like a different issue. Can you submit a separate ticket for this and it will be addressed?

    Thanks,
    Brendan

    Posts: 28 Topics: 10
    | Permalink

    OK – I think I know what’s happening. This mis-ordering of past events seems to be caused by the Advanced Post Types Order plugin. I’m following up with them for a fix. Thanks!

    Posts: 2500
    | Permalink

    Hi Jacob,

    Good to know. I will let our devs know for possible conflict as well.

    Thanks,
    Brendan

    Posts: 6240 Topics: 17
    | Permalink

    Hi Jacob,

    Just wanted to let you know that we’ve been doing some bug reports cleanup and we found out the issue reported here is not present with our latest versions of our plugins.

    This means that it may have been fixed before while working on other fixes/improvements.

    Please update the plugins and see if it works on your end.

    I’ll go ahead and close this thread, but if you still experience any problem, please open a new ticket and we’ll be happy to help you with the troubleshooting.

    Best,
    Victor

    | Permalink