Help Desk

Location Search not working

  • Posts: 3 Topics: 2
    | Permalink

    I am having an issue where the location search never returns any results. I currently have events to display in list view but no matter what I type into the location search filter, it always returns no results were found.

    I had gone through and disabled all plugins along with switching back to the default wordpress theme on a staging site and was still having the issues.

    I have tried searching by city, state, and zip codes and can not get any results to display. Can you please help? Thanks.

    ========================
    PLEASE LEAVE FOR SUPPORT
    Reporting the same issue as: https://theeventscalendar.com/support/forums/topic/location-search-error/

    Posts: 5471 Topics: 13
    | Permalink

    Hi Andre!

    Thanks for getting in touch with us. Let me help you troubleshoot that issue.

    I tried to reproduce the same in my own local installation but could’t.

    Could you please go to your wp-admin and while editing a venue see if the latitude and longitude fields are filled in? You can discover those fields by clicking the ‘Use latitude + longitude’ checkbox.

    If they show up empty, then please try saving the venue again with the ‘Use latitude + longitude’ option unchecked, and see if the coordinates get filled in.

    Please, let me know about that.

    Thanks,
    Victor

    Posts: 3 Topics: 2
    | Permalink

    Hi Victor,

    So I went into the venue and the use latitude + longitude boxes are unchecked and there is nothing displaying. If I check the box, input fields appear but no lat or long is being filled in. I have tried saving the venue after just checking the box and it just goes back to an unchecked box. I have also just tried resaving the venue with the unchecked box but it still does not get filled in after.

    Could it be an issue with google api key? I did go into google and make sure the api was active and the key was correct. Should I try creating a new key to see if that works?

    Thanks

    Posts: 5471 Topics: 13
    | Permalink

    Hi Andre!

    Thanks for trying that out.

    So the reason the location search is not working is because the venues don’t have the lat and long coordinates needed.

    If the coordinates are not being generated when saving the venue, then this means the Google API is not fetching the data somehow.

    When on the edit venue page and after saving the venue, could you please see if there are any console errors by inspecting the page? We have an article that explains how to do that here > https://theeventscalendar.com/knowledgebase/using-google-chrome-developer-tools

    Trying with a new Google API key is also a good idea to see if it changes anything.

    Additionally, please enable WP_DEBUG and WP_DEBUG_LOG. This will create a debug.log file inside the /wp-content directory.

    After that, try saving the venue a few times, so that in case there is an error, it will be saved into the debug.log file. Please share that log file with us so we can see if any problem from there.

    Let me know how that goes.

    Thanks,
    Victor

    Posts: 3 Topics: 2
    | Permalink
    This reply has been marked as private.
    Posts: 5471 Topics: 13
    | Permalink

    Hi Andre!

    Thanks for coming back with all that info.

    The venue issue seems really strange. Do you experience the same while creating a new venue from scratch?

    The debug.log info only shows PHP notices coming from the bb-theme-builder plugin, which by the look of the directory structure seems that it does customize something in our plugins.

    I know you have tried deactivating all other plugins and switching to a default theme for the location search not working. Could you please go through the testing for conflicts guide but this time to see if you can create/save the venue information and see if the lat/long coordinates do get saved?

    If you see no difference in those conditions, then we’ll need to do some deeper troubleshooting.

    Let me know how that goes.

    Thanks,
    Victor

     

    Posts: 3 Topics: 2
    | Permalink
    This reply has been marked as private.
    Posts: 5471 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 7
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Location Search not working’ is closed to new replies.