Issue after Event Calendar Pro to 3.9.1 and Event Calendar Tickets to 3.9

Home › Forums › Ticket Products › Event Tickets Plus › Issue after Event Calendar Pro to 3.9.1 and Event Calendar Tickets to 3.9

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #941711
    wickedsimple
    Participant

    I upgraded both plugins on the site I manage and now when you go to add a ticket to the shopping cart you get a Error 500 – Internal Server Error.

    BUT…if I go directly to the page that has the shopping cart shortcode the page appears.

    #941730
    wickedsimple
    Participant

    I should note that I also update WooCommerce today. After reading another community member’s post who is having the exact same issue, it appears that it’s with WooTickets.

    here is the URL:

    http://www.owlwayscreativestudio.com

    If you try to add the ticket to the shopping cart you get the Internal 500 Server Error.

    Any assistance you can provide is much appreciated!

    Donna

    #941842
    Brian
    Member

    Hi,

    Sorry for the issues you are having with the update to WooCommerce 2.3

    Can you try this coding to see if that helps resolve the issue:

    // -----------------------------------------------------------------------------
    // The code below this comment should be added to the theme's functions.php file
    // -----------------------------------------------------------------------------

    // Compatibility fix to help run WooCommerce Tickets 3.9 with WooCommerce 2.3.x
    if ( class_exists( 'TribeWooTickets' ) ) {
    // Form reference to ticket processing callback
    $wootickets = TribeWooTickets::get_instance();
    $callback = array( $wootickets, 'process_front_end_tickets_form' );

    // Switch to a later action
    remove_action( 'init', $callback );
    add_action( 'wp_loaded', $callback );
    }

    Let me know if that works for you.

    Thanks

    #942910
    Jeff
    Participant

    You should broadcast that one or do a quick update – because I was having the same problem, and the code fixed it immediately. Fingers crossed it doesn’t turn up again.

    #942986
    Brian
    Member

    Hi Jeff,

    We have updated WooCommerce Tickets to 3.9.1 to resolve the issue. The coding above should be removed before upgrading to WooCommerce Tickets 3.9.1 or later.

    I am going to close this ticket, but if you need anything else related to this topic or another please post a new topic on the forum and we can help you out.

    Thanks

Viewing 5 posts - 1 through 5 (of 5 total)
  • The topic ‘Issue after Event Calendar Pro to 3.9.1 and Event Calendar Tickets to 3.9’ is closed to new replies.