Help Desk

Having trouble installing ECP

  • Posts: 8 Topics: 3
    | Permalink

    I installed Events Calendar 2.0 fine by uploading a zip file from the wordpress admin section (via the plugins upload area). Acitaved it and then started using it and it worked just fine.

    Then I purchased Events Calendar Pro and tried to install it the exact same way and I received an error:

    Fatal error: Call to undefined function get_current_screen() in /home/content/s/l/o/slowfoodhunt/html/wp-content/plugins/events-calendar-pro/vendor/advanced-post-manager/tribe-apm.php on line 180

    I can still at this point navigate through the website, but no longe the admin area until I manually delete the plugin from server via FTP.

    I made a short screencast of my troubles here:
    http://youtu.be/N6-BUi7vYcw

    Any assistance would be greatly appreciated.
    -David

    Posts: 2
    | Permalink

    I am having the same problem. Breaks every time with php error. Any help would be great.

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hey guys. Thanks for reaching out and apologies to hear you’re having problems here. Two points on this:

    1. I see that in that screencast, you’re not using the latest version of WordPress. What version is that you’re on there? Would always suggest updating to the latest if at all possible.
    2. Might you have wp_debug set to “true” in your config file? The only instances I’ve seen like this are when people have that turned on.

    Let me know about those two points and I’ll see what I can do to help get this cleared up for you.

    Posts: 8 Topics: 3
    | Permalink

    Hey Rob,

    I installed the latest version of WordPress and it worked!

    Thanks! and great product! Congrats on the release of 2.0

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Thanks David 🙂 Awesome to hear that did the trick. If anything else arises going forward, give me a shout and I’ll do what I can to help.

    Ryan: Let me know if you’re still having issues.