Help Desk

filter bar always show on mobile

  • Posts: 5 Topics: 4
    | Permalink

    hi

    how can i set the filter bar always visible even on mobile phones, practically always use the desktop version

    Posts: 5043
    | Permalink

    Hello,

    If you go under Events > Settings > Filters and set the “Filter Bar default state” setting to “Show on initial page load”, Filter Bar should show automatically in both mobile and desktop views. Can you give this a try and let me know if it works for you?

    Thanks,

    Jennifer

    Posts: 5 Topics: 4
    | Permalink

    thanks,

    i’ve tried yet several times, but with this options simply the bar on mobile disappered after less than a second…

    Posts: 5043
    | Permalink

    Hello,

    I think this is likely being caused by a conflict with your theme or possibly with another plugin. Can you try running through the steps outlined here to test this out? You can use the free Duplicator plugin to create a staging environment if you don’t have one already.

    Can you also share your full system info with me?

    Thanks,

    Jennifer

    Posts: 5 Topics: 4
    | Permalink
    This reply has been marked as private.
    Posts: 5043
    | Permalink

    Thanks for sending that over! Just to clarify, did you deactivate all other plugins (besides The Events Calendar and Filter Bar) and switch to a default theme at the same time? If so, were you still seeing this issue in that default environment?

    I see that you disabled Filter Bar on your live site…We are not able to login to the backend of user sites, but if you can send me a link to this page on your staging site (with all other plugins disabled and a default theme like Twenty Seventeen enabled), I can do some more testing on my end.

    Thanks,

    Jennifer

    Posts: 5 Topics: 4
    | Permalink

    i’ve tried deactiveting all the plugin but nothing.

    now the filter bar disappers on mobile and olso on desktop get some problem….

    what could i do?

    Posts: 5043
    | Permalink

    Hello,

    Thanks for deactivating the plugins…Since I’m not able to recreate this on my end and don’t see any other reports of similar issues from other users, I believe that this is coming from your theme. Were you still seeing this using the default Twenty Seventeen theme? If so, can you please send me a link to your testing environment with Twenty Seventeen enabled and all other plugins disabled so that I can do some testing on my end?

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink