Help Desk

Events not Showing in Admin

  • Posts: 31 Topics: 11 Answers: 1
    | Permalink

    I am having an issue with my events not showing in the wp-admin. They appear fine on the website. The wp-admin shows All (xxx) | Published (xxx)| Draft(xxx) but the screen says no events. If I deactivate the EVENTS PRO module the events show except recurring of course. I tried reactivating the PRO module but nothing shows still. I updated my functions.php with the add_action(‘init’, ‘tribe_allow_large_joins’);
    function tribe_allow_large_joins(){
    global $wpdb;
    $wpdb->query(‘SET SQL_BIG_SELECTS=1’);
    }
    But it didn’t help. Please any assistance to resolving this issue would be greatly appreciated.

    Posts: 3519 Answers: 115
    | Permalink

    brightenyourview,
    Thanks for getting in touch! Can you verify that you don’t have any filters applied that would be causing no events to show? You can do this by going to your Events List page and clicking the ‘Clear’ button in the Filters section (screenshot).

    If that’s not the case, then I would suggest increasing the Memory limit available to WordPress.

    If that still doesn’t fix the issue, then I would check to make sure that you’re not including a large amount of Events on the listing page, by going to ‘Screen Options’ and decreasing the number of events that you’re displaying per page (screenshot).

    Give those suggestions a try and let me know if you’re still having problems here. Thanks! 🙂

    -Casey-

    Posts: 31 Topics: 11 Answers: 1
    | Permalink

    I had no filters and I tried increasing the memory limit and I changed the number of events to display to 5 and I still don’t see ALL | PUBLISHED and DRAFT events. All the published events do appear on the event calendar viewed on the website.

    Posts: 3519 Answers: 115
    | Permalink

    Beth,
    Could you try following these instructions to test for plugin/theme conflicts, and let me know what you discover? Thanks! 🙂

    -Casey-

    Posts: 31 Topics: 11 Answers: 1
    | Permalink

    I tried disabling all plugins and using the default theme I still could not see the events in the admin unless I deactivate PRO I even tried deleted the PRO plugin and reinstalling it and I still cannot see the events in the admin. Any other thoughts? Thanks Beth

    Posts: 3519 Answers: 115
    | Permalink

    Beth,
    I suspect that this might be an issue with your web host’s configuration. Could you try increasing the Memory Limit of PHP & WordPress to see if that resolves the issue?

    Posts: 31 Topics: 11 Answers: 1
    | Permalink

    I did that and it still does not show my published or draft events in the admin

    Posts: 3519 Answers: 115
    | Permalink

    Could you send me your web server’s database logs? I’d like to investigate those further to see if any errors are occurring when trying to retrieve the list of Events. Thanks! 🙂

    -Casey-

    Posts: 31 Topics: 11 Answers: 1
    | Permalink

    I don’t have any database logs but I exported the posts and post-meta to my dev database and website which is set up the same with version 3.1 and I can see the events when PRO is turned on could it be something in the options table somewhere?

    Posts: 31 Topics: 11 Answers: 1
    | Permalink
    This reply has been marked as private.
    Posts: 3519 Answers: 115
    | Permalink

    Beth,
    So, it does appear that your host disallows large database joins, but I’m not sure why that first snippet didn’t work. Can you try temporarily reverting to the default 2013 theme and then try adding this snippet to the 2013 theme’s functions.php file and see if it does the trick: ?

    I want to narrow this issue down and see if it’s related to your theme somehow. Thanks! 🙂

    -Casey-

    Posts: 31 Topics: 11 Answers: 1
    | Permalink
    Correct Answer

    Casey Thank you so much I was able to resolve the issue with my host and this is all set.

    Beth

    Posts: 3519 Answers: 115
    | Permalink

    Great! Thanks for confirming that this got you sorted. Since it looks like you’re all set, I’m going to mark this thread “Answered” and close it out.

    By the way, if you have a minute or two, we would love it if you’d write a few words for us here: http://m.tri.be/lo

    Thanks in advance. 🙂

    Cheers,
    Casey