Help Desk

Default view for events

  • Posts: 4 Topics: 2
    | Permalink

    I have the default view for events set for Calendar however, it always defaults to the event list. Any assistance is appreciated.

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hi again Sara. What’s the URL path for your events? Are they still set to /events? You should if that’s the case be seeing grid at that URL. My guess is maybe you have a link somewhere going to /events/upcoming, which is the URL for the list regardless of what’s set to default.

    Let me know if that’s the cause. Otherwise I can keep looking into it for you.

    Posts: 4 Topics: 2
    | Permalink

    Hi Rob…

    This is the URL for the Events Page

    http://www.365plainfield.com/?post_type=tribe_events

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Hi Sara. Thanks for posting that; what slug have you configured for the broader events page? Did you manually set it to ?post_type=tribe_events, versus just /events?

    Posts: 4 Topics: 2
    | Permalink

    I did not change anything. I just added the the event plug in.

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Thanks for confirming. I guess what I’m asking is, where did you get that URL for ?post_type=tribe_events? You should go to Settings –> The Events Calendar, then set the URL slug as /events. The URL it generates automatically (appears underneath the slug field) should be where your events live. Make sure to resave your permalinks page after this.

    Let me know what happens from there and I can keep trying to troubleshoot.

    Posts: 24 Topics: 5 Answers: 3
    | Permalink

    @Sara, i had the same problem, check this post, maybe it will be useful: https://theeventscalendar.com/support/forums/topic/something-strange-when-i-click-my-events-base-url

    Posts: 4278 Topics: 105 Answers: 467
    | Permalink

    Thanks Roberto.

    Sara: let me know if Roberto’s suggestion above helps.