Help Desk

Creating tickets with WooCommerce buggy

  • Posts: 10 Topics: 7
    | Permalink

    Hi there!

    I’m trying to switch our RVSP events to be ticketed events and created a test site for that purpose. I downloaded WooCommerce and updated all plugins and themes to the most recent version. There seems to be something wonky going on with the tickets for an event now.

    1) The section that says “venue” is blank and I cannot add a venue type.
    2) Clicking “add another organizer” does nothing except save the event
    3) Trying to create a new ticket (or even a RSVP) does the same thing – it just reloads the page and says “event saved”

    I’ve disabled my usual theme tried a new theme (2017) and it still happens. I deactivated all plugins and it seems to be the WooCommerce plugin that is causing the issue.

    Any thoughts?

    Thanks so much!
    Gabrielle

    Posts: 6230 Topics: 17
    | Permalink

    Hi Gabrielle!

    Thanks for reaching out to us. Let me help you troubleshoot that issue.

    When experiencing those issues, could you please see if there are any console errors by inspecting the page? We have an article that explains how to do that here > https://theeventscalendar.com/knowledgebase/using-google-chrome-developer-tools/

    Also, please enable WP_DEBUG and WP_DEBUG_LOG ? This will create a debug.log file inside the /wp-content directory.

    After that, try reproducing the issue a few times, so that in case there is an error, it will be saved into the debug.log file. Please share that log file with us so we can see if any problem from there.

    Thanks,
    Victor

    Posts: 10 Topics: 7
    | Permalink

    Hi Victor!

    There are no console errors when I inspect element. I created the debug logs and whenever I click “create ticket” or “create RSVP” I get the same error saying:
    “[26-Feb-2018 21:53:20 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 92 bytes) in /home1/ibxwalkt/public_html/ibx_events/wp-includes/meta.php on line 837”

    I’m going to reach out to my hosting company tomorrow morning and see if this is something they can help with. Perhaps it’s a memory issue on their end?

    I don’t know how to trouble shoot the missing option for adding Venue to the page, but perhaps one thing effects the other? I’ll report back in the A.M. with my findings.

    Thank you!

    Posts: 6230 Topics: 17
    | Permalink

    Hey Gabrielle,

    Thanks for testing that out and for keeping us posted.

    We’ve seen this notice pop up for customer in other threads. In most of those cases, it boiled down to the hosting service not allowing enough memory to PHP. As a starting point, I would suggest following the steps outlined in this WordPress Codex article — it walks through how to increase that memory limit.

    If, however, that does not do the trick, I would recommend reaching out to your hosting provider and asking them for assistance in increasing the PHP memory limit. That should resolve the issue but, if for some reason it does not, please don’t hesitate to let us know and we can dig into this further.

    Regarding the Venue option missing from the edit page, it could be a different issue, so let’s first tackle the memory limit error. If after solving the fatal error the venue option is still missing, I’d recommend you try testing for conflicts again to see if any difference under default conditions.

    Let me know how that goes.

    Thanks,
    Victor

    Posts: 10 Topics: 7
    | Permalink

    Hi Victor!

    The Venue issue has worked itself out, and I can now click the save buttons. However, I keep getting an error that reads “Connection lost. Saving has been disabled until you’re reconnected. We’re backing up this post in your browser, just in case,” after trying to save a ticket. It does not have that issue when saving the post that the ticket is attached to. I reached out to my hosting company and they upped our Memory Limit and the Apache timeout limit, but the issue keeps happening. Any thoughts?

    Thanks so much!

    ETA – Actually, I lied, it still happens when I save a post, just not as frequently.

    • This reply was modified 9 months, 2 weeks ago by  Gabrielle. Reason: New information
    Posts: 6230 Topics: 17
    | Permalink

    Hi Gabrielle!

    Thanks for keeping me posted about the issue.

    The “Connection lost” message you are getting looks like it could be a connectivity issue on your end. It means that as the site is not able to save the ticket because of loosing connection, it will save the information locally so that you can save it later.

    It’s good that your hosting increased the memory and timeout limit. Could you please verify if you are still getting the PHP Fatal error or any other error on the debug.log file?

    Let us know about it.

    Thanks,
    Victor

    Posts: 10 Topics: 7
    | Permalink

    Hi Victor!

    I don’t seem to have any errors in my debug log today but I’m still getting the connection error. Some additional observations:

    • I tried a default 2017 theme with the same results.
    • I deactivated all plugins except my event calendar plugins and same results.
    • There are no connection issues on our other site that is hosted on the same server.
    • I’m moving our site to this new hosting account and have another installation that is live on another server. That live installation does not have any issues. The only difference (besides where it’s hosted) is that I’m running older versions of all the events plugins on the live site. Events Tickets is version 4.5.7 and Events Tickets Plus is version 4.5.3. The site with the errors are versions 4.6.3.1 and 4.6.2 respectively.

    Thanks!

    Posts: 6230 Topics: 17
    | Permalink
    This reply has been marked as private.
    Posts: 10 Topics: 7
    | Permalink
    This reply has been marked as private.
    Posts: 6230 Topics: 17
    | Permalink
    This reply has been marked as private.
    Posts: 6230 Topics: 17
    | Permalink

    Hi Gabrielle!

    Thanks for your patience while I performed the tests.

    I was able to test your database in a local installation and made several attempts to create and edit tickets and could not replicate any of the issues you are having.

    It seems strange that you are not getting any errors logged into your debug.log file. Did you enable WP_DEBUG > https://codex.wordpress.org/Debugging_in_WordPress and WP_DEBUG_LOG > https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG ?

    Were you able to increase the WP_MEMORY_LIMIT > https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP ? Did you see any difference?

    Going back to the “Connection lost. Saving has been disabled until you’re reconnected” message, try changing the AUTOSAVE interval > https://codex.wordpress.org/Editing_wp-config.php#Modify_AutoSave_Interval  you may want to switch to a “160” value, probably increasing it even further.

    I would also suggest you get in touch with the hosting provider to see if they can offer some insight about this errors.

    Let us know how that goes.

    Best,
    Victor

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Creating tickets with WooCommerce buggy’ is closed to new replies.