Help Desk

Community Reqwrite Slug not working in Community plugin

  • Posts: 14 Topics: 5
    | Permalink

    This is what I have in Community Plugin settings:

    Community rewrite slug
    community
    The slug used for building the community events URL – it is appended to the main events slug. Your current community events URLs are
    The slug used for building the community events URL – it is appended to the main events slug. Your current community events URLs are

    https://boulder.earthcommunity/add
    https://boulder.earthcommunity/list

    As you can see, there is no “/” after the domain name boulder.earth to separate the slug. Quite simply a bug. Please advise…

    Thanks!

    Posts: 5926
    | Permalink

    Hi Damjan,

    Thanks so much for reaching out!

    As a first troubleshooting step, can you try flushing your permalinks by going to Settings < Permalinks and Save Changes.  You will want to clear your browser and site cache as well after doing this.

    Let me know if that helps!

     

    Thanks,

    Jaime

     

    Posts: 14 Topics: 5
    | Permalink

    Permalink structure updated. Browser cache cleared. No change. 🙁

    Posts: 14 Topics: 5
    | Permalink

    Hey Jaime, just wondering where I bee to look next? Thanks!

    Posts: 14 Topics: 5
    | Permalink

    where I *need to look

    not “bee” to look

    🙂

    Posts: 5926
    | Permalink
    Correct Answer

    Hi Damjan,

    When I visit https://boulder.earth/events/community/add, the submission form shows up as expected.

    Where are you seeing the re-direct to the page without a slash?

    Let me know!

     

    Thanks,

    Jaime

    Posts: 14 Topics: 5
    | Permalink

    Oh, great!

    In the community plugin settings, it says “https://boulder.earthcommunity/add” — so there is no /events/ (and it’s missing the first “/”). I was not aware that the url is supposed to have /events/ in the url because it’s wrong in the settings.

    Anyway, thanks for clearing it up!

    Posts: 14 Topics: 5
    | Permalink

    FYI

    Posts: 5926
    | Permalink

    Hi Damjan,

    I’m not sure why it appears that way in your settings.  Perhaps it is because the URL is so long.

    In any case, it seems that things are working as expected.

    Let me know if you have any other questions!

     

    Thanks,

    Jaime

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink