Help Desk

Community Events Prevents Non-Admin Login Access to Dashboard

  • Posts: 3 Topics: 4
    | Permalink

    If I have multiple users, only Admin level users can login to WordPress at all if the Community Events add-on is activated. If an Editor, Author, or Contributor user tries to login, they are immediately sent to the main homepage URL every time. There’s no way to access any admin or dashboard URLs, they all get sent to the homepage.

    If I deactivate this Community Events plugin alone, everything works as expected and all user levels can login and interact as expected. Please advise.

    Posts: 3395
    | Permalink

    Hi Heather,

    I’m sorry you’re running into this issue with Community Events! It sounds like it’s conflicting with something else on your site. Can you try running through the steps outlined here to test for any conflicts with your theme and other plugins? Please make sure that you have WP_DEBUG enabled during the testing and copy/paste any error messages that appear in your reply.

    If you don’t have a testing environment and don’t want to do this on your live site, I would recommend the freeĀ WP Staging plugin, which will let you create a quick copy of your live site that you can use for testing.

    Please let me know what you find!

    Thanks,

    Jennifer

    Posts: 2 Topics: 2
    | Permalink

    Have you checked the Community settings? There is a setting in Community Events that allows you to block certain roles from accessing the dashboard. If you go to Events>Settings and Click on the Community tab, there is a section titled “Access Control”. Check those settings, a they may be the problem.

    Posts: 3 Topics: 4
    | Permalink

    LIFE…SAVER! Thank you, Jeff! That was it exactly. The solution is often the easiest (most overlooked), I suppose. Are those Access Control settings all checked by default perhaps? To my knowledge, this was a fresh install of the Community Events plugin just recently and I hadn’t modified the settings personally.

    Posts: 3395
    | Permalink

    Hi Jeff, thanks for pointing that out! I’m glad that worked for you Heather. Those settingsĀ should be unchecked by default.

    If you run into any other issues, please let us know!

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Community Events Prevents Non-Admin Login Access to Dashboard’ is closed to new replies.