Help Desk

change

  • | Permalink

    i put the edit translation files in languages/plugins directory, but somehow it gets changed and i lose the translations. i upload the files again a lot of times but the next day the translations are back to the original?!

    Posts: 10005 Topics: 1
    | Permalink

    Good evening Peter and welcome to the Events Calendar Support forum!

    Thank you for reaching out to us.

    We are sorry to hear about the language files disappearing on you.
    I would love to help you with this topic.

    Our plugins actually do not touch the files located in the /wp-content/languages/ folder.
    That being said, our plugin does give priority to the files located in that folder over the ones located in the /lang/ folder of our plugin.

    Can you confirm if you are putting your language files in the /wp-content/languages/ folder or if you are putting them in the the /wp-content/plugins/the-event-calendar/lang/ folder ?

    Best regards,

    Geoff B.

    | Permalink

    Geoff thank you for your mail. They are in both directory folder. After upload the translations they are visible, but the next day they are gone.

    thank you and best regards

    Posts: 10005 Topics: 1
    | Permalink
    Correct Answer

    Good afternoon Peter,

    Thank you for writing back.

    I have a couple of follow-up questions for you:

    1. When you say they are gone, do you mean that they are replaced by a different file?
    2. Are you using a caching plug-in?
    3. Can you tell me the exact path you are putting your language files in under the /wp-content/languages/ folder ?
    4. What happens if you remove your language files under the /lang/ folder of our plugin?

    Best regards,

    Geoff B.

    | Permalink

    1. i mean you can see the original translation of the plugin
    2. no caching plugin
    3. /wp-content/languages/ and /wp-content/languages/plugins
    5. I can still see my changes but after i delete yesterday the files today the files are back

    Posts: 10005 Topics: 1
    | Permalink

    Good afternoon Peter,

    Thank you for answering my follow-up questions.

    I have another follow-up question for you. Can you tell me which language you are using on your site? (I would like to run some additional tests) ?

    The fact that the files you have deleted yesterday appear back on your website is very strange.

    It sounds like there is an automatic backup solution for file change detection in place.
    If it’s possible that someone is doing maintenance for your site or that you are under a managed WordPress web hosting plan?

    Best regards,

    Geoff B.

    | Permalink

    Good afternoon Geoff this is in German. I am the admin and the site is without any automatic running backups specially the files we talking about. what i can see is that happen every night at 2:00. hope this will help

    Posts: 10005 Topics: 1
    | Permalink

    Good afternoon Peter,

    I have to say that this is very odd. The fact that this happens everyday at the same time looks like a CRON job.
    I am not sure if that is set at the server level or in a plug-in (e.g.: a security plugin could be responsible – scans for any file change and replaces them if they have changed).

    In other words, I do not think that this is actually related to our plugin’s behaviour as much as something else going on with your installation.

    As a first troubleshooting step, could you please provide us with your complete system information using the instructions found in the following link?

    https://theeventscalendar.com/knowledgebase/sharing-sys-info/

    Best regards,

    Geoff B.

    | Permalink

    ok. where should i send the infos you need they should be private. maybe you can send me a link to the the wright form.

    thank you and best regards

    Posts: 10005 Topics: 1
    | Permalink

    Good afternoon Peter,

    I totally understand your desire to keep this info private.

    Just to set expectations, as stated in my last reply, it does look like the issue is actually not related to the translation files themselves as much as your server’s behaviour. If that’s the case, then this means that we might be limited in the level of support we can provide unfortunately.

    You can send me your info at geoffroy@tri.be

    Have a good week-end,

    Geoff B.

    Posts: 10005 Topics: 1
    | Permalink

    Good evening Peter,

    Thank you for the system information and for the invitation to login.
    Unfortunately, our policy does not allow us to log in to clients websites for several reasons, including liability.

    That being said, there are a couple of things about your installation that would require tuning (this will probably help):

    1. You cannot have a “real” page that has the “schulungen” slug.
    2. Under Events -> Settings -> General, you cannot have the same URL for the calendar and the individual event slug (schulungen). They absolutely need to be different from one another.
    3. Still in Events -> Settings -> General, navigate to the bottom of the page and click on the “Merge duplicates” button
    4. When you are done please re-save your permalinks.

    With that in mind, I am limited into the technical support I can provide for something that is happening at a server level for you.

    My recommendation would be to talk to your web hosting company about this and if they do not have a solution for this, you might want to consider getting somebody to help you out or simply changing web hosting companies.

    Best of luck,

    Geoff B.

     

     

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team