Help Desk

Can't Add New Event, Venue or Organizer: Getting Http 500 Error

  • Posts: 16 Topics: 7
    | Permalink

    Hello,

    I have just done a fresh install of WordPress and all my plugins. I had an issue with hackers.

    But I am still using the same database and image files.

    All plugins and wordpress are the most up to date versions.

    I have both the free and pro versions of the Events Calendar installed.

    All events in the database are showing on the site. But I am unable to add a new event/organizer/venue

    When I try to do so I get a page saying

    currently unable to handle this request.
    HTTP ERROR 500

    I deactivated all plugins (except the EC & EC Pro) and switched to the Twenty Sixteen theme that comes with wordpress.

    I still got the same error.

    I activated the debug mode in EC and found this error message in my log

    [29-Dec-2017 08:36:46 UTC] the-events-calendar/common – Log: Initializing Tribe Events on Dec, 29th at 08:12:46 am

    I also read in the forum someone suggesting to go to the EC Settings and resave them in the WordPress Dashboard. I tried that but that didn’t work either.

    Here is some information about my server:

    Apache Version 2.4.29
    PHP Version 5.6.32
    MySQL Version 5.6.36-cll-lve
    Architecture x86_64
    Operating System linux
    Shared IP Address 94.130.41.130
    Path to Sendmail /usr/sbin/sendmail
    Path to Perl /usr/bin/perl
    Perl Version 5.16.3
    Kernel Version 3.10.0-714.10.2.lve1.4.61.el7.x86_64

    There is more information about my system in the private area.

    I also noticed a couple of plugins like Wordfence and W3 Total Cache added information to our .htaccess file. Could this be a possible cause?

    Any help in getting this resolved so we can start adding events again would be greatly appreciated.

    Thanks
    Eric

    Posts: 16 Topics: 7
    | Permalink

    I tried to edit my post and add more information to private area but not sure if it was posted.

    Can you tell me if you received my server information and .htaccess file info?

    I also posted the error that is being generated (my host emailed it to me)

    Here it is again just in case… i edited out my domain name though just in case and used mydomain instead

    PHP Catchable fatal error: Argument 2 passed to Tribe__Events__Meta__Save::__construct() must be an instance of WP_Post, null given, called in /home/mydomain/public_html/wp-content/plugins/the-events-calendar/src/Tribe/Main.php on line 3043 and defined in /home/mydomain/public_html/wp-content/plugins/the-events-calendar/src/Tribe/Meta/Save.php on line 33

    Posts: 1245
    | Permalink

    Hi Eric,

    Thanks for the info. Based on the error this looks like something may be missing from the core files. Best thing to do is replace the wp-admin and wp-includes folder along with all core files in root directory with a fresh copy. However, I’m sure you know this but make sure you leave the wp-config.php as is.

    Let me know how that goes.

    Thanks,
    Brendan

    Posts: 16 Topics: 7
    | Permalink

    Thanks for responding Brendan,

    I reinstalled wordpress by uploading and overwriting all the files by FTP except for the wp-content directory and .htaccess / wpconfig files…

    This didn’t fix the issue

    So I tried checking for a corrupt .htaccess file (I renamed the .htaccess file to .htaccess-old, then went to settings>permalinks and resaved to generate a new .htaccess file) This didn’t help either

    In addition, to not being able to add new events, I am not able to add new pages or new posts to my site. I am getting the same Http 500 error as when I try to add a new event.

    So what I did was deactivate the Events Calendar Pro and Events Calendar plugins.

    After doing that I was able to get a page to load for a new post and new page but it is missing the content box (area where you input your content) & it says “You are currently editing the page that shows your latest posts”

    Very strange

    So I deactivated my theme and switched to the Twenty Seventeen theme. I tried to add a new page or post and ended up with the same issue. Missing the content input area and saying “Your currently editing the page that shows your latest posts”.

    Next I deactivated all other plugins.

    With a barebones wordpress with no plugins and using the Twenty Seventeen theme. I still was getting the same issue when trying to add a new page or post.

    I just wanted to see what would happen if I activated only the Events Calendar and Events Calendar Pro plugins. This ends up giving me an HTTP 500 Error when I try to add a new page, new post, or new event.

    I remember reading on a few wordpress.org support threads that someone had a similar issue (not exactly the same as I am having)… without posting all the details they reset and saved the permissions for the database user. I tried it but this didn’t help either.

    I deactivated the EC & ECP plugins, deleted them from the server, and redownloaded the plugins and reinstalled fresh copies of EC 4.6.8 and ECP 4.4.20.1

    This didn’t help.

    When I reinstalled a fresh copy of WordPress and all the plugins I actually jumped from

    EC 3.7 & ECP 3.7 to EC 4.6.8 and ECP 4.4.20.1

    Could this be the problem?

    I noticed the 3.7 version of ECP is still available for download from my Modern Tribe / Events Calendar Account. But the EC 3.7 version doesn’t seem to be available.

    I was thinking of testing out my site with the old plugin versions.

    I do have a copy of EC 3.7 from my WordPress backups but don’t want to use it because I am nervous that hackers may have changed the files. Is there anywhere I can get a clean copy of EC 3.7?

    Should I even try installing the older versions of the plugins to see if this resolves the issue?

    I am also open to any other thoughts or suggestions you might have to trouble shoot this problem.

    Thanks Eric

    Posts: 16 Topics: 7
    | Permalink

    Hi Brendan,

    Thanks for your time.

    We have found the issue.

    My host suggested we clear the database and restore it from a back up.

    This seemed to fix the issue and everything seems to be working fine now.

    He said that when we moved the database that phpmyadmin may have missed a line because the database was very large.

    So he restored the database through the server console to avoid any timeouts. And it seems to have done the trick!

    Thanks again and happy new year!

    Eric

    Posts: 1245
    | Permalink

    Hi Eric,

    Happy New Year! I was going to have you reinstall WordPress but glad you figured it out and for posting the resolution in case anyone else runs into this issue.

    Thanks,
    Brendan

    Posts: 4
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Can't Add New Event, Venue or Organizer: Getting Http 500 Error’ is closed to new replies.