Help Desk

Can't add different URL for website in translated event (WPML)

  • | Permalink

    Hi,

    I’m using WPML to translate the events to a secondary language. Most of it works fine but for some reason the Event Website URL can’t get a different value than the default language. Whenever you try to change the url in the translation it just doesn’t save. Any idea what causes this? All the other fields work just fine.

    Thanks,

    | Permalink

    My mistake: the other fields seem to default to the standard language too after re-saving the event. Am I missing a setting somewhere to make the extra fields translatable?

    | Permalink

    (Sorry, the location and event organizer fields can be translated, I missed that setting. Event URL still can’t be translated though.)

    Posts: 6978 Topics: 2
    | Permalink
    Correct Answer

    Hi Eva,

    This forum is dedicated to issues with the translations of our plugins, and not to issues with multi-language / WPML issues.

    If you need help with the above topic and you have a valid license to Events Calendar Pro or another plugins, then please log in to your account at theeventscalendar.com and open a thread in the respective forum. In this case, to speed up support, please share your system information (https://theeventscalendar.com/knowledgebase/sharing-sys-info/) and give us a detailed description of the issue.

    If you are without a license you can post your question in the wordpress.org repository here: https://www.wordpress.org/plugins/the-events-calendar/support/ and either one of our support folks or the community will help you out.

    To get you started, you might want to check out this article, might help you solve the issue:

    https://theeventscalendar.com/knowledgebase/setting-up-the-events-calendar-with-wpml/

    Thanks and cheers,
    Andras