Help Desk

Aggregator/import history exclamation points inside circle

  • Posts: 9 Topics: 3
    | Permalink

    Since upgrading last week to 300 imports per day, I am having more issues than ever with Events Aggregator. But, I’ll start with the most prominent of them.

    Most of my imports are not going through–instead, the history tab displays an exclamation point inside a red circle for many, many of the scheduled imports. Please let me know what this symbol means and how to resolve it.

    Posts: 6080 Topics: 16
    | Permalink

    Hi Cynthia!

    I’m sorry to hear you are having problems with your imports. Let me help you with this.

    The red exclamation symbol means it’s a failed import. To know more about the fail import you can hover over the symbol and a message should show up.

    Could you please let us know the messages you are getting for those failed imports? Are you having failed imports for a specific import or all of them?

    What happens if you manually run those failed imports? Do they work?

    Also, please navigate to your wp-admin > Events > Help and send us a screenshot of the Event Aggregator System Status.

    Let us know about that.

    Thanks,
    Victor

    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 6080 Topics: 16
    | Permalink

    Hi Cynthia!

    Thanks for coming back with all that information.

    In addition to the “import failed” message, does it show any other message regarding the reason of why it failed? Please let me know about this.

    In the meantime, I will reach out to the dev team to investigate this further and will get back to you when we have something.

    Thanks for your continued help and patience while we work on this.

    Best,
    Victor

    Posts: 9 Topics: 3
    | Permalink

    It does not say anything else–just Import Failed.

    Please note that this is sort of urgent because I need to go live on my website soon (was hoping for this week), and the calendar is a central feature. I need to have confidence that the Aggregator is doing its job. THanks.

    Posts: 6080 Topics: 16
    | Permalink

    Hi Cynthia!

    Thanks for your continued help and patience so far.

    We’ve checked if any of your imports were being blocked by our Event Aggregator servers and there are no records of failed imports on our side. We do see there are many imports successfully running for your license key, so it seems they are mostly working so far.

    First, could you please enable WP_DEBUG and WP_DEBUG_LOG ? This will create a debug.log file inside the /wp-content directory.

    After that, wait until you get a new failed import, so that in case there is an error, it will be saved into the debug.log file. Please share that log file with us so we can see if any problem from there.

    Also, are you getting failed imports for all import sources or just some of them? Could you please share those failed import URLs so we can run some tests on our end?

    Please let us know about that.

    Thanks,
    Victor

    Posts: 9 Topics: 3
    | Permalink

    Hi,

    I will take the actions you mention (re debug).

    I just checked (10 a.m. CST), and over the past 24 hours, only 1 import failed. This is the least number of failures since I activated the aggregator. The failed import was https://www.facebook.com/odiesfoodtrucks/, but I just reran it manually, and it did not fail. I will wait for another fail and send you that URL (after enabling the debug).

    I installed a cache cleaning plug-in yesterday afternoon–perhaps this helped?

    THe failed imports seemed to be more related to “when” than the source. I don’t see a pattern of a given source not importing over and over.

    Thanks for your help.

    Posts: 6080 Topics: 16
    | Permalink

    Hi Cynthia!

    Thanks for coming back with that information. Glad to know it seems to be working back as normal.

    I tried running imports for the Facebook URL and, while it does not have any future events in it, I am able to run the imports on my end.

    I installed a cache cleaning plug-in yesterday afternoon–perhaps this helped?

    I’m not really sure about this. If you say the failed imports seem to relate to a specific point in time and not to the sources, then it makes me think of some sort of connectivity issue.

    I’ve just re-checked your license and can still see many successful imports for the last three days. Please keep us posted about how that is working on your end.

    Thanks,
    Victor

    Posts: 9 Topics: 3
    | Permalink

    I am still getting a lot of failed imports, and also many duplicate events n(more than in the past), which are not accounted for by a duplicate scheduled import source. Some events are also being missed altogether, perhaps because of the failed imports.

    WP_DEBUG and WP_DEBUG_LOG were enabled yesterday, 3/15.

    As you mention, there are many successful scheduled imports. I don’t know what the standard should be, but I would like ALL of the 150+ scheduled imports to run daily without failures.

    Please let me know what the next step is now that WP_DEBUG and LOG are enabled. I am not familiar with how these work–I had to hire someone to enable them for me.

    THank you.

    Posts: 6080 Topics: 16
    | Permalink

    Hi Cynthia,

    Thanks for following up with this and for enabling WP DEBUG.

    WP_DEBUG (https://codex.wordpress.org/Debugging_in_WordPress) and WP_DEBUG_LOG (https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_LOG) works by logging errors (if any) that occur on your site in a debug.log file that is saved in the /wp-content directory.

    Could you please share that log file with us so we can see if any errors from there?

    Also, please share with us one or two screenshots for different pages of the imports history tab where we can see some of the failed imports. We’ll compare those specific dates/times with the records on our end and see what we find.

    For the duplicate events issue, please point us out to the specific events that are being duplicated and the import source where those are coming from. We’ll run some tests on our end and see if we can reproduce.

    Thanks again for your patience and help so far.

    Best,
    Victor

    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 6080 Topics: 16
    | Permalink
    This reply has been marked as private.
    Posts: 9 Topics: 3
    | Permalink
    This reply has been marked as private.
    Posts: 6080 Topics: 16
    | Permalink
    This reply has been marked as private.
    Posts: 7
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team

    | Permalink

The topic ‘Aggregator/import history exclamation points inside circle’ is closed to new replies.