Help Desk

Filter Bar selection throws URL output in browser "Title"

  • Posts: 202 Topics: 72
    | Permalink

    Selecting any filter in the “Filters Bar” results in the URL being displayed as browser window title. This looks horrible and is no good for those wanting to share or link to the specific result. This needs fixing.

    Posts: 202 Topics: 72
    | Permalink
    This reply has been marked as private.
    Posts: 18146 Topics: 17 Answers: 973
    | Permalink
    This reply has been marked as private.
    Posts: 202 Topics: 72
    | Permalink

    @Barry: It seems that you have replied here, but I can’t see your message as it is “marked as private” ?

    Posts: 18146 Topics: 17 Answers: 973
    | Permalink

    I do apologize … I’ll repost here (the bug causing this issue with private staff replies ought to be solved from here on though):

    That definitely isn’t ideal – however, I’m not sure that I can replicate it.

    Can you confirm if this happens with no other plugins but ours and only a default, unmodified theme running? I get the impression from previous threads you may have custom code in place relating to the title element and SEO-related plugins which may be impacting.

    Posts: 202 Topics: 72
    | Permalink

    Hi Barry: No matter what we do ECP acts competely strange regarding titles. You are obviously aware of this (and the none support of Yoast SEO) as you made a snippet that somewhat compensate. We use one of the most advanced theme’s from GoodLayers with no problems at all (with any plugins) except from ECP. Modern Tribe needs to do af full overhaul of the way title’s are displayed (and not displayed) with full support of SEO plugins.

    Posts: 202 Topics: 72
    | Permalink
    This reply has been marked as private.
    Posts: 202 Topics: 72
    | Permalink
    This reply has been marked as private.
    Posts: 18146 Topics: 17 Answers: 973
    | Permalink

    There is certainly some strange effects with the title and we’re going to look into that – however, I still can’t replicate the problem you’re facing whereby the URL becomes the title. I know you said you deactivated all other plugins – but did you also switch to a default theme?

    Posts: 202 Topics: 72
    | Permalink

    We did not switch to any default theme as this is a live client site. Nor can I see what difference it should make as we are using the best theme already? This problem is part of the non-supported SEO compability in ECP as explained. That’s why we are using your snippet in the first place – to get any title output at all other than the URL.

    Posts: 202 Topics: 72
    | Permalink
    This reply has been marked as private.
    Posts: 18146 Topics: 17 Answers: 973
    | Permalink

    I appreciate your frustration, but we simply can’t guard against every eventuality with every combination of theme and plugin.

    That said, as above, we are going to look into some title issues that we can replicate without other plugins/non-standard themes. I can’t say whether that will resolve the particular issues you are facing, which sound like they are highly specific to your own installation and may therefore boil down to integration issues rather than being the result of bugs per se.

    Nevertheless – we can’t spend any more time on this.

    That being the case I’ll go ahead and close this thread. Sorry we couldn’t get closer to a resolution for you in this instance.