Help Desk

Display of recurring events

  • | Permalink

    On our calendar, the first view is a “month” view and every day is showing three events, which are the same for almost every day of the month because they are events that started in the past and run into the future.

    We noticed that in the “List” view, there is a check box that says “show only the first instance of a recurring event”. This makes for a better view, but it only applies to the “List” view and our default is the “Month” view.

    Do you have any recommendations so that the “Month” view of the Calendar section is improved? We wanted to make sure that there are no settings for this that we have missed.

    Posts: 6978 Topics: 2
    | Permalink
    Correct Answer

    Hey Karen,

    Thanks for using the Events Calendar.

    Here in the translations forum, I’m afraid we do not provide technical support. I would ask that you take any technical support questions across to our wordpress.org forum – our staff scan it periodically and other community members may also be able to help out.
    https://wordpress.org/plugins/the-events-calendar/

    If you have purchased a plugin from us, please login and post in the premium forums for that plugin and we can help you out there:
    https://theeventscalendar.com/support/forums/

    However, to give you an idea on the solution, paste this into your child theme’s style.css file, which should do the trick:

    .tribe-events-month .tribe-recurring-event-child {display:none}

    Thanks again!

    Andras