Help Desk

After updating – No comments yet – can't be translated.

  • Posts: 24 Topics: 11
    | Permalink

    I can not find the words – no comments yet – in any of the plugins. I use LOGO translation to translate. It is only after updating the event calendar and installing events ticket that I have got the problem.
    Is there anyone who can help.

    Posts: 10005 Topics: 1
    | Permalink

    Good morning Preben and welcome back!

    Thank you for reaching out to us.
    I would love to help you with this topic.

    I can not find the words – no comments yet – in any of the plugins.

    You are right. This string is not found in our plugin.
    You will find it either in WordPress’ strings or in your WordPress theme’s strings.

    Let me know if you need additional help finding them.

    Have a great day!

    Geoff B.

    | Permalink

    Thanks for getting back to me.

    I have found the text string in the WordPress core. It has been translated in the core, but the translation does not appear in the event. Who should I contact to correct this.
    You can see it here. http://mcikast.dk/event/test-tur/

    (<div id=”comments”>

    No comments yet.

    </div>)

    Yours sincerely

    Preben

    Posts: 10005 Topics: 1
    | Permalink

    Good evening Preben,

    Thank you for writing back.

    This is most likely caused by the WordPress theme you are using.

    There is a good chance the “No comment” string is hardcoded in the comments.php template or that the domain of the strings are set to the theme’s language files.

    Could you please send me a copy of the latest version of your WordPress theme / child theme via a link to a .zip file link (stored Dropbox or Google Drive) so that I can run some tests on my end ?

    Please ensure you are using the latest files as found on your actual website.
    This way I will get access to any updates or customizations you might have made.

    Best regards,

    Geoff B.

    | Permalink

    Hi Geoff.

    I am very grateful for the help. Hope that you find a solution. Tell me if there’s anything else you need.

    I have attached a link to woo themes Canvas. https://www.dropbox.com/s/vhn5v2w0lfdxt6x/canvas.7z?dl=0

    with best regards
    Preben

    Posts: 10005 Topics: 1
    | Permalink

    Good afternoon Preben,

    Thank you for your kind words.

    As I suspected, the culprit is found in /Canvas/comments.php around line 81

    This leaves you with 3 options:

    1. Check with Woothemes if they have an up to date language file for that theme in your language
    2. Create a language file for your language yourself (which seems to be the case, but I am not sure it is up to date – updating from the pot file needs to be performed)
    3. Edit line 81 and hardcode the translated term for “No comment” (and any other string from that template that needs

    Let me know how that goes.

    Best regards,
    Geoff B.

    Posts: 65
    | Permalink

    Hey there! This thread has been pretty quiet for the last three weeks, so we’re going to go ahead and close it to avoid confusion with other topics. If you’re still looking for help with this, please do open a new thread, reference this one and we’d be more than happy to continue the conversation over there.

    Thanks so much!
    The Events Calendar Support Team