Help Desk

Additional Fields in FilterBar – No Search Results

  • Posts: 116 Topics: 48
    | Permalink

    Good Morning from Germany,

    we use a collection of filters in our FilterBar Setup. Besides others we use a Additional field “DozentIn” for search and all worked fine for month.

    No the specific search for a Dozent does not bring a result. But after pressing Browser refresh Button (independtly which Browser I use) the results appear.

    So I do the following: Go to side: https://finde-deinen-malkurs.de/kurse/

    Search for Dozentin/Dozent = “Ute Zander” https://finde-deinen-malkurs.de/kurse/?tribe_paged=1&tribe_event_display=list&tribe__ecp_custom_2=Ute+Zander

    No Result.

    The I press refresh and the results appear.

    Please help.

    P.S. In our staging environment we don’t use the cache plugin but the behavior for this kind of search is exactly the same.

    Best regards
    Uwe

    Posts: 6978 Topics: 2
    | Permalink

    Grüss dich Uwe

    Thanks for reaching out!

    I have checked your page and found something else as well.

    If I go to the Kurse page (https://finde-deinen-malkurs.de/kurse/) and navigate to the next page, then I don’t see the events of Ute Zander. There should be one on July 10.

    It looks like that it’s a recurring event, is that right?

    Do you have the option ‘Recurring Event Instances’ set to show only the first instance of a recurring event? That might cause this behavior. The setting is under Events > Settings > General tab > Recurring Event Instances.

    Please check and let me know.

    Grüsse
    Andras

    Posts: 116 Topics: 48
    | Permalink

    Dear Andras,
    thanks for your reply and sorry for the late answer but your mail was landed in my spam mail 🙁

    So, back to the topic.

    Yes, we use recurring events and we had the setup to “only show the first event”. I changed the setup accordingly but does not lead to a change.

    The problem still exists – and meanwhile we get claims from our organizer accordingly. So, independent which entry you select for “Dozentin/Dozent” – you never get a result. Only if you refresh the browser.

    We need urgently a solution for this problem.

    Regards Uwe

    Posts: 116 Topics: 48
    | Permalink

    Hi Andras,

    After several tests I found the following:

    the problem occurs only for custom fields and only if the custom field value are two words – means the data base request has to be completed by a special sign like “+” ode “%”.

    Maybe that helps additionally.

    Best regards Uwe

    Posts: 6978 Topics: 2
    | Permalink

    Thanks Uwe,

    Indeed, this extra info helps. We recently discovered the issue that if the additional filed value contains a space, then the filter doesn’t work.

    The workaround is what you said, omitting the space and using a different character.

    The issue is already on high priority and we are working on it. I do hope we will be able to release a fix in the next MR. Please hang in there.

    I am going to set the status of this ticket to “pending fix” and we will update it once the fix is released.

    If you have any new questions or issues please create a new ticket and we’ll help you out.

    Thanks and cheers,
    Andras

    Posts: 6240 Topics: 17
    | Permalink

    Hi Uwe!

    Just wanted to share with you that a new release of out plugins is out, including a fix for this issue 🙂

    Find out more about this release → https://theeventscalendar.com/maintenance-release-for-the-week-29-july-2018/

    We apologize for the delay and appreciate your patience while we worked on this.

    As always, we suggest to setup a dev/staging site so you can make all plugin updates without disrupting the live site. Please update the plugins and let us know if the fix works for your site.

    Best,
    Victor

    Posts: 116 Topics: 48
    | Permalink

    Dear Victor,

    thanks for heading up.
    We installed the newest version and it works again!

    Viele Grüße von

    Uwe Matern

     

    Posts: 6978 Topics: 2
    | Permalink

    Hi Uwe,

    Thanks for reporting back! We’re super happy to hear this got fixed for you!

    Since this issue is resolved I am going to close this ticket for now. If you need anything else related to this topic or another please create a new ticket and we’ll be happy to help.

    Cheers,
    Andras

    PS: We’d be grateful if you would give us feedback on your satisfaction with support. Just click on one of the classy looking emojis below. 🙂 If you can spare a few words, that’s even better. Thanks!

    PS2: If you like our plugins, and you didn’t yet do so 🙂 we would also be happy to receive a review in the wordpress.org repository. Much appreciated!
    https://wordpress.org/support/view/plugin-reviews/the-events-calendar/
    https://wordpress.org/support/view/plugin-reviews/event-tickets/

     

    | Permalink