Help Desk

From Bad to WORSE: Event Aggregator Still Still not working

  • Posts: 42 Topics: 13
    | Permalink

    I was asked to make my own thread:
    https://theeventscalendar.com/support/forums/topic/event-aggregator-still-not-importing-properly/#dl_post-1385736

    In response to your question:
    Sadly, no the problem now seems to be worse.
    Where before, I had an orange warning !, saying it’s been delayed?
    Now I’ve got a red warning!, saying “Event Aggregator server has blocked your request.”

    Posts: 2034 Topics: 1
    | Permalink

    Hey Saif,

    Welcome back to our forums and thank you for opening this new thread as requested! I’m really sorry to hear that our latest release didn’t help you to solve this problem yet!

    To get started, could you please let me know from where you are importing your events (i.e. Google calendar, Facebook, etc.)? Can you send us the link via private reply so we can take a look?

    Is it happening with scheduled imports or one-time imports? For scheduled imports, are you able to run them manually?

    Also, could you please access your Dashboard, head over to Events > Help and share a screenshot of the Event Aggregator System Status? Do you see any errors in there?

    If everything seems fine, could you please delete your EA key from Events > Settings and save, then disconnect your old license from https://theeventscalendar.com/license-keys/, and after that re-enter your license again in your wp-admin settings?

    Thanks!

    Patricia

    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink
    This reply has been marked as private.
    Posts: 2034 Topics: 1
    | Permalink
    This reply has been marked as private.
    Posts: 42 Topics: 13
    | Permalink

    My importer still randomly fails, stating the aggregator server has blocked my request.
    It says to contact you to know why; which I did 2 months ago. A month ago you guys told me it’s in the devs hands now.

    It’s been a month; can I please have an update?

    Posts: 17847 Topics: 17 Answers: 973
    | Permalink

    I’m really sorry about that, Saif. I’m unsure why it would be blocking your request and have flagged that problem specifically with the team. As soon as we hear more we’ll be sure to update you.

    Posts: 17847 Topics: 17 Answers: 973
    | Permalink

    Saif: thanks for your patience so far.

    Just as Patricia tried previously, I’ve upgraded your license key (temporarily) but this time to accommodate 1,000 imports per day. Let’s see if that impacts the problem and we can evaluate further from there.

    Something else I’m not completely clear on but could be worth a shot: if this is not already in place, can you ask the team at WP Engine to enable ‘true cron’ (ie, configure crontab to reliably run scheduled tasks in WordPress every 15 minutes). If this isn’t already in place, it may facilitate smoother running of imports particularly at any times of day where your site is not in receipt of sufficient traffic to trigger them organically.

    Thanks again!

    Posts: 42 Topics: 13
    | Permalink

    True Cron – I’ve sent the request to my host; I’m not with WPEngine right now, as the salesmen promised what the techs won’t do 😀 So. Not really sure I’m going to move over to them at this point.

    1,000 upgrade – great; except it might not be needed anymore?

    Update: So, the thing that bothered me in the past – repeat imports of the same thing, over, and over again. Like, every time I reviewed the recent imports: there were plenty of repeats and something had been imported in the last 15 minutes, if not hour, etc. However around 11 hours ago, that stopped? And the errors changed too.

    First off: I don’t see any repeats. 10 imports, 10 feeds. Then, there’s the new error at 10 hours out;

    11 hours ago:
    “Import failed: The import being fetched is not queued up for importing. Please try the import again.”
    “Import failed: The import being fetched is not queued up for importing. Please try the import again.”
    “Import failed: Event Aggregator server has blocked your request. Please try your import again later or contact support to know why.”

    10 hours later though? Something I don’t think I’ve ever seen before:
    “Import failed: The daily limit of 1 import requests to the Event Aggregator service has been reached. Please try again later.”

    I haven’t updated any plugins in the last 12 hours. So, maybe something changed on your end? All I do know, while the scheduled imports page looks concerning (lots of ‘last import = unknown), since 95% of my imports are daily, and I set up most of them to do it ONLY at night, or basically 5 am or so? 8 hours makes sense. Hopefully this time tomorrow, we’ll know if your 1,000 increase helped.

This thread hasn’t seen any activity for quite some time and we are not accepting further replies.

If you need further help with this or any other issue, please create a new topic (you can of course include a link to this one if that helps to provide additional context) and one of the team will be only too happy to help.