Help Desk

Event submission form – Translations not working after update.

  • Posts: 10 Topics: 6
    | Permalink

    Hey there,
    Just wanted to let you know that a couple of the translations that did work before the latest update doesn’t any more. In my case it with the Swedish translation. Will this get fixed very soon in an upcoming update or should I edit the themer’s guide templates to get it right for now, temporarily? The translations is in the .po file. They just don’t show up on the site anymore.
    One example is:

    Images that are not png, jpg, or gif will not be uploaded.
    Images may not exceed 32 MB in size.

    Another is:

    Select or Create a Venue

    Then also in the Wp-admin on the submission form – There is:

    Location

    …that doesn’t get translated either, even though it in the .po file as well. (This one was before the update too.)

    Posts: 6123 Topics: 2
    | Permalink

    Hi Emil,

    Thanks for the heads up and sorry about this bug. We are aware of this and should be fixed in the next maintenance release.

    The issue most likely comes from the .po translation files not being updated.

    What you can do it open the .po file with a suitable application (e.g. PoEdit) and from the Catalog menu choose Update from POT…, then select the .pot file. Check the translations, then save and upload the .po and .mo files to your server. Hopefully this should do it.

    Note, there is one string on the Community Events submission form that will not get translated at the moment, which is “All Day Event” next to a checkbox.

    Possible fix for this is: the namespace on line 150 needs to be changed in
    wp-content\plugins\the-events-calendar-community-events\src\views\community\modules\datepickers.php from:

    <?php esc_html_e( 'All Day Event', 'tribe-community-events' ); ?>

    to

    <?php esc_html_e( 'All Day Event', 'the-events-calendar' ); ?>

    I hope this helps. Let me know if you have any more questions.

    Cheers,
    Andras

    Posts: 10 Topics: 6
    | Permalink

    Thank you,
    It worked indeed to change to ‘the-events-calendar’ but the latest update from yesterday was terrific and made that change superfluous.
    All I had to do to Update from POT today. I hade to mess around quite a lot
    to get it to work but eventually it worked very nicely.
    It solved all the rest of the problematic strings as well. (Almost)
    Woohoo!

    Except for one…

    Start/End:

    Have I made a mistake or is it still unresolved?
    Any solutions for that?
    Thanks in advance.

    Posts: 10 Topics: 6
    | Permalink

    Your ‘the-events-calendar’ quickfix worked for this as well, so never mind.

    • This reply was modified 1 year, 5 months ago by  Emil.
    • This reply was modified 1 year, 5 months ago by  Emil.
    Posts: 6123 Topics: 2
    | Permalink

    Hi Emil, thanks for reporting that back!

    Since the topic seems resolved I am going to close this ticket, but if you need anything else related to this topic or another please post a new one in the forum and we will be happy to help you out.

    Cheers,
    Andras

    PS: If you like our plugins, and you didn’t yet do so 🙂 we would be happy to receive a review in the wordpress.org repository. Thanks!
    https://wordpress.org/support/plugin/the-events-calendar/reviews/
    https://wordpress.org/support/plugin/event-tickets/reviews/

    PS2: We’d be also grateful if you would give us feedback on your satisfaction with support. Just click on one of the classy looking emojis below. 🙂 If you can spare a few words, that’s even better. Doublethanks!

     

This thread hasn’t seen any activity for quite some time and we are not accepting further replies.

If you need further help with this or any other issue, please create a new topic (you can of course include a link to this one if that helps to provide additional context) and one of the team will be only too happy to help.