Announcing Event Tickets 4.10.11.1

Hey Folks! Today’s speedy update restores publishing events with our Block Editor using WordPress 5.3. Users were reporting that events with tickets were not publishing. We’ve squashed those bugs.

In most cases, you will be able to take advantage of automated updates directly in WordPress, but if that’s unavailable for some reason, you can download the plugins from the downloads page in your account, then update manually.

The changes are short and simple this time:

Event Tickets

  • Fix – When using the new block editor with WordPress 5.3, users couldn’t publish or update events which have tickets attached to them. Clearly, we need that working. We now force null values to 0 for _tribe_ticket_capacity so that RSVPs save correctly in 5.3 block editor.
  • Fix – We are also bypassing REST update/delete of virtual meta key _tribe_tickets_list so that events will save in WP 5.3.
  • Fix – We set some values to null (or an empty string which gets evaluated the same) instead of deleting them, as does WordPress in some cases. The new validation in REST fails on those unless we explicitly them it that null is acceptable. We now allow null to be sent for REST API updates in WordPress 5.3 for certain meta fields that we intentionally send null for but don’t match the registered schema type.
  • Fix – Handle the onRequestClose action in element.js to prevent Attendee Information modal closing when clicking within the modal.

 

Not Updated This Release

The following plugins have not been updated this release and will remain at the version numbers specified here: